Custom Filter "Address" now "Unroutable"

tbutler

Active Member
Feb 11, 2004
41
5
158
For years -- long before cPanel added support for "+" addresses, I've had something similar to that feature via a "global" filter configured in cPanel where [email protected] (regex: `[email protected]`) would forward to another account where I could deal with it as I wished. In other words [email protected] forwards to [email protected] (this is by design so spammers cannot just take off the _anything 'local_part_suffix' and get to my real box.

It has worked great and I've used it with hundreds of different suffixes over a decade or more. However, it has abruptly stopped working with a recent cPanel update. Now, if I try to send mail to said "fake" address, it is returned as "unroutable."

I cannot for the life of me figure out how to reconfigure exim in WHM to tell it to pay attention to the fact that a filter exists and to accept that e-mail even though there isn't a real email address at [email protected] I tried this, which did not work:

Code:
mycustomroute:
     driver = redirect
     domains = mydomain
    condition = ${if eq {$local_part_data}{tbutler}}
     local_part_suffix = _*
    no_verify
    data = [email protected]
How can I tell cPanel/WHM to not reject tbutler_* but to instead let the mail come in so that the filter can process it?
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
6,943
918
313
cPanel Access Level
Root Administrator
Hey there! I believe this is related to a recent case I opened with our developers in the following thread:


as the Global Filters are not properly handling the wildcard characters. I've left a note on the internal case referencing this thread as well, but you can follow along with this page if you are signed in to our ticket system for updates on the issue:

cPanel >> Global Email Filters not properly handling wildcard characters