The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Custom PHP versions per account

Discussion in 'General Discussion' started by rinkleton, Aug 16, 2016.

Tags:
  1. rinkleton

    rinkleton Active Member

    Joined:
    Jul 16, 2015
    Messages:
    29
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Cleveland
    cPanel Access Level:
    Root Administrator
    So we've gotten ourselves into a pickle with outdated server software and php versions. Actually upgrading the code isn't an option unfortunately.

    Ultimately the issue is paypal and other entities eliminating support for TLS 1.0 and 1.1.

    From what I've read, the way to upgrade openssl to a new enough version is to upgrade the linux version. However the upgraded linux version doesn't support the php version we need to be at (5.2... but 5.3 would probably do).

    Is it possible to upgrade the the server to the newest everything and manually set each account to use an older version of php? And by older I mean OLD.
     
  2. rpvw

    rpvw Well-Known Member

    Joined:
    Jul 18, 2013
    Messages:
    123
    Likes Received:
    36
    Trophy Points:
    28
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    You might like to have a look at the CloudLinux solution - it gives users the options of using PHP 4.4, 5.1, 5.2, 5.3, 5.4, 5.5, 5.6 and 7.0 and all the PHP obsolete versions are 'hardened' by CloudLinux applying all the available patches to them.
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    You could install cPanel version 56 on the new OS by preconfiguring the release tier before starting the installation. This is documented at:

    Installation Guide - Customize Your Installation - Documentation - cPanel Documentation

    This will allow you to use PHP 5.3 with EasyApache 3, and delay the upgrade to EasyApache 4 until the websites no longer require the EOL PHP version.

    Thank you.
     
Loading...

Share This Page