The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Customer email going to /dev/null

Discussion in 'E-mail Discussions' started by trumpetx, Oct 9, 2006.

  1. trumpetx

    trumpetx Member

    Joined:
    Apr 3, 2004
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    I currently have a customer who reported his email stopped coming in sometime in the past 3 days. I have confirmed this and by checking my exim_mainlog I believe that his mail is being sent to /dev/null.

    I have no idea why or how to change this... his settings in cPanel are correct, and I have no idea how this could have been changed. It's possible my prognosis is incorrect. So, here's what I've found.

    The failing message:
    Code:
    2006-10-09 09:26:08 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1GWv8t-0003br-4s
    2006-10-09 09:26:09 1GWv8t-0003br-4s => /dev/null <xxxx@xxxxx.xxxxx.com> R=central_user_filter T=**bypassed**
    2006-10-09 09:26:09 1GWv8t-0003br-4s Completed
    2006-10-09 09:26:09 1GWv8r-0003bj-Tp => xxxx <contact@xxxxx.org> R=sa_localuser T=local_sa_delivery
    2006-10-09 09:26:09 1GWv8r-0003bj-Tp Completed
    
    The good message (tested on an address on my account -- same server):
    Code:
    2006-10-09 09:19:50 1GWv2s-0003Vs-NE <= david@xxxxxxx.com H=(xxxx.xxxxxxxxx.net) [204.89.253.13] P=esmtp S=730 id=452A4C72.1000001@xxxxxxxx.c
    om T="(no subject)"
    2006-10-09 09:19:50 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1GWv2s-0003Vs-NE
    2006-10-09 09:19:50 1GWv2s-0003Vs-NE => frank <frank@xxxxxxx.com> R=virtual_user T=virtual_userdelivery
    2006-10-09 09:19:50 1GWv2s-0003Vs-NE Completed
    
    Any ideas what setting needs to be changed? Either from the administrator end or the client end? This is happening with some, not all (confirmed), of my customers.
     
  2. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,384
    Likes Received:
    23
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Check to see if the user has any e-mail filters set up. I would bet that they do and one of those filters is being triggered. I don't know if its possible to determine which particular filter is causing this (I've never been able to figure it out), but you can remove all of the filters by doing:

    mv /etc/vfilters/domain.com /etc/vfilters/domain.com.old

    on the shell.
     
  3. trumpetx

    trumpetx Member

    Joined:
    Apr 3, 2004
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    that worked!


    now, why on earth would it work for some customers and not others? is this a setting that they changed?
     
  4. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,384
    Likes Received:
    23
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Users have the ability to create e-mail filters in their control panel. Personally, I would not recommend using e-mail filters. Filters work in just the way you have seen. A message that matches a specific filter is removed, the user never knows the message was not receive, the sender never knows the message was not received, it can just create a lot of problems.

    Also to keep in mind, by using e-mail filters, if you are filtering the body of a message for a specific term, that term may show up in the uuencoding of an e-mail attachment, meaning that the message would not be received. In my opinion, the better solution is to use SpamAssassin if you are wanting to control your spam as it offers better solutions to this than by just creating e-mail filters.
     
  5. ProLamer

    ProLamer Active Member

    Joined:
    May 17, 2005
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    Very useful answer

    It solved my problem as well.

    Thanks
     
Loading...

Share This Page