The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Customise Bug - 11.25

Discussion in 'General Discussion' started by DARPA, Jan 4, 2010.

  1. DARPA

    DARPA Member

    Joined:
    Jan 2, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Branding Editor x3 Bug - 11.25

    When clicking on Customise via WHM to edit template a "Failed Login" page is instead displayed. This is a bug, no problems prior to update.

    Any ideas?
     
    #1 DARPA, Jan 4, 2010
    Last edited: Jan 4, 2010
  2. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,460
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Please provide the exact path in WHM where this Customize function is. Also which version were you running before the update?
     
  3. DARPA

    DARPA Member

    Joined:
    Jan 2, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Sorry, the function is titled "Branding".

    ../scripts8/branding

    When clicking on x3 branding editor a Login Failed page is displayed.

    ../xfercpanel/cpanel?theme=x3&goto_uri=/frontend/x3/resellers/branding/branding.html

    Running the latest CURRENT release prior to upgrade to 11.25

    According to CPHulk, the user trying to access when clicking on the x3 branding editor is not root but user: "cpanel" so that may be a clue. If I try to manually login as root when the failed login screen is displayed, no success.

    Note, this issue can trip CPHulk, so beware to make sure your IP is whitelisted or you will need to stop CPhulk via SSH.
    /user/local/cpanel/etc/init/stopcphulkd

    to start again, startcphulkd
     
  4. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,460
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Thank you for the added details. From your report it sounds like one of the following Tweak Setting is checked:

    Disable login with root or reseller password into the users' cPanel interface. Also disable switch account dropdown in themes with switch account feature


    Only allow reseller to log in to users' cPanel interface with reseller password


    Please try unchecking one or both and trying the branding editor again.
     
Loading...

Share This Page