vincentg

Well-Known Member
May 12, 2004
172
4
168
new york
Third time around for this problem

Cpanel updates are causing PHP and mail problems.
The main items that get effected are phpmyadmin which no longer will view tables
Also email stops to work properly.
The view mail queue will not show all items in the queue when this happens.

This was sent to me from a client.
-----------------------------------------
An error was detected while processing a file of BSMTP input.
The error message was:

421 Lost incoming connection

The SMTP transaction started in line 0.
The error was detected in line 3.
0 previous messages were successfully processed.
The rest of the batch was abandoned.
421 Lost incoming connection
Transaction started in line 0
Error detected in line 3
------------------------------

I have to run /scripts/updatenow first else using /scripts/upcp --force will just hang!

After I run both all is well again untill the next update breaks it all again!!!
This only happens on my Centos server so I suspect it's a Centos issue.

Any ideas when this will be addressed by Cpanel?

Vin
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,437
33
473
Go on, have a guess
It won't get addressed unless you have reported it to cPanel in a support ticket or in bugzilla - have you done either? If you have, then you'll have to wait until they do fix it if they find a problem. If not, then you're going to be waiting a long time :)
 

vincentg

Well-Known Member
May 12, 2004
172
4
168
new york
I suspect the problem is not on all update servers.

This doesn't happen every day - more like once in a while.

My guess is they don't have the servers synced.
Depending on which server you get you are either upgraded or wrecked.

Vin
 

xphost

Well-Known Member
Nov 12, 2003
76
0
156
today server 10.0.0-CURRENT_138

hang on 00.20 when executes /etc/cron.daily
 

vincentg

Well-Known Member
May 12, 2004
172
4
168
new york
I have not had a major problem with updates but this one problem seems to be constant.

Seems that there is a resurface of this Spam Assassin problem.

An error was detected while processing a file of BSMTP input.
The error message was:

421 SMTP incoming data timeout - message abandoned

In looking over the old threads one did bring up the fact that a dual CPU seemed to be more affected then others.

I am running a P4 3 Ghz with Hyper Threading - this is seen as a dual CPU.
Spam Assassin may not be calling correct libs which could be part of the problem.

This is an issue that is going on for over one year with Spam Assassin.

Is there a fix for it yet in the near future?

Vin
 

vincentg

Well-Known Member
May 12, 2004
172
4
168
new york
I read through the many pages reguarding this problem

As far as I know they never came up with a solid solution.
Looked back at my old notes from last year and I ran the update scripts for Spam Assassin.

/scripts/perlinstaller Digest::SHA1
/scripts/perlinstaller --force Mail::SpamAssassin --- don't run extra tests
/etc/rc.d/init.d/exim restart
/scripts/restartsrv spamd

Hope it works.