Darkorb, instructions to turn off suexec

AlaskanWolf

Well-Known Member
Aug 11, 2001
537
0
316
Fremont CA
I need instructions on turning this off, it was turned on by default in the layer1 or frontpage layer installs

I am moving 600 accounts from a cpanel server onto this one and that server does NOT have susexec on, and from what i heard, it will break cpanel if these accts are moved under this current state of
suexec
 

MichaelShanks

Well-Known Member
PartnerNOC
Aug 20, 2001
104
0
316
simply renameing /usr/local/apache/bin/suexec to another name is meant to disable suexec from starting up.

anyone agree?
 
B

bdraco

Guest
Just rm -f the suexec binary and reinstall the frontpage rpm
 

AlaskanWolf

Well-Known Member
Aug 11, 2001
537
0
316
Fremont CA
Nick

rather then short answers, please helpus in this and give us more information

I removed the binary, and redownloaded the fp-5.0-upgrade.sea, reran it, but when a new site is created, it shows up as

#NameVirtualHost 216.218.184.66:80
<VirtualHost 216.218.184.66>
ServerAlias www.test.com test.com
ServerAdmin [email protected]
DocumentRoot /home/testcom/public_html
BytesLog domlogs/test.com-bytes_log
User testcom
Group testcom
ServerName www.test.com
CustomLog domlogs/test.com combined
ScriptAlias /cgi-bin/ /home/testcom/public_html/cgi-bin/
</VirtualHost>


Can you tell me if suexec is still active or ????
 

AlaskanWolf

Well-Known Member
Aug 11, 2001
537
0
316
Fremont CA
not surprising...it reappeared...please darkorb, give us clear step by step instructions that work, if i did something wrong, please tell me, because all you said was \"remove the suexec and redownload the frontpage rpm\"

I couldnt find a rpm, but i could find the .sea file in layer1 downloads......



[email protected] [/usr/local/apache/bin]# dir
./ ../ ab* apachectl* apxs* dbmmanage* htdigest* htpasswd* httpd* logresolve* rotatelogs* suexec*
 

dzevad

Well-Known Member
Oct 7, 2001
95
0
306
Try this:
easiest method is if you installed fp-upgrade.sea already you then have directory called that name, go to it and then to apache dir in it. Start apache installation manually, it will ask you what do you want to be installed with apache, just uncheck suexec and continue, it will start with install and install it without suexec, then after it just install front page from same place manually.

Or this:
rename suexec in usr/local/apache/bin to something else, and delete/comment out (#) all User Group lines in httpd.conf and restart apache :)

i must say i have suexec and i\'m not having any problems with it currently....