The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Database at xt:Commerce

Discussion in 'Database Discussions' started by inegwe, Apr 13, 2009.

  1. inegwe

    inegwe Member

    Joined:
    Apr 13, 2009
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    I am trying to install a database at xt:Commerce.
    There are the following data needed:

    Code:
    -Database-Server
    -Username
    -Password
    -Database-Name
    If I enter all the things right (in my opinion), I get the following error:

    Code:
    Access denied for user '[I]USERNAME[/I]'@[I]IP[/I]' (using password: YES) [I]//(reduced)[/I]
    I tried all possible combinations but anyway the data are wrong.
    Maybe there are a few different usernames and/or passwords (one for the 'normal' access and one for the database)?

    Thank You!
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,446
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Did you create the database first using the MySQL Databases section of your cPanel?

    Once you create the database there, you should create a user as well, and then add the user to that database. All on that one page. On completion of the last step of adding user to that new database, you'll be shown the details for it. username_dbusername added to username_dbname

    With those details and your dbusername password you should be good to go to install your script when asked for the details of the new database.
     
  3. inegwe

    inegwe Member

    Joined:
    Apr 13, 2009
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Thank you for your quick answer, but the access is still denied...

    My example:
    Code:
    Database: myName_shop
    Current user: myName_smith
    Acces hosts: %.tvrus.tv
    This user was added to this database.
    PHP:
    $dbh=mysql_connect ("localhost""myName_smith",
    "<PASSWORD HERE>") or die('Cannot connect to the database because: ' mysql_error());
    mysql_select_db ("myName_shop");
    My data at xt_Commerce:
    Code:
    Database-server: tvrus.tv
    Username: myName_smith
    Password: [I](which I defined while creating a user for DB)[/I]
    Database: myName_shop
    Can anybody please help my to find my mistake?
     
  4. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Is your database server set to tvrus.tv or to localhost?
     
  5. inegwe

    inegwe Member

    Joined:
    Apr 13, 2009
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    phpMyAdmin sais, it is localhost
    I have just tried to change my database-server into localhost, but the access is still denied.
     
  6. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Where did you try changing this? Was this a file with configuration settings in it?
     
  7. inegwe

    inegwe Member

    Joined:
    Apr 13, 2009
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    No, I changed it just in the installation of the xt:Commerce (xtc_installer).
     
  8. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    You may wish to contact the maker of that script. They may be able to elaborate on why you would receive such an error.
     
Loading...

Share This Page