The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Database issues, please help

Discussion in 'General Discussion' started by evisions, Oct 26, 2004.

  1. evisions

    evisions Well-Known Member

    Joined:
    Jan 25, 2004
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    I've just moved my sites over from one server to another, and now I am having some database issues. I copied the databases over from the old server and I think that probably caused the issue, but I'm not sure how to go about correcting it. All the site database work fine, but the global databases are having issues. Here are the symptoms:

    - Eximstats keeps failing

    - Horde gives this error:
    DB Error: connect failed

    [line 108 of /usr/local/cpanel/base/horde/lib/Prefs/sql.php]

    - PHPMyAdmin in WHM gives this error:
    Wrong username/password. Access denied.

    Can someone please help me resolve these issues?
     
  2. evisions

    evisions Well-Known Member

    Joined:
    Jan 25, 2004
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Can anyone help with this?
     
  3. rvskin

    rvskin Well-Known Member
    PartnerNOC

    Joined:
    Feb 19, 2003
    Messages:
    400
    Likes Received:
    1
    Trophy Points:
    18
    Go to WHM / MySQL / Reset MySQL root password.
     
  4. evisions

    evisions Well-Known Member

    Joined:
    Jan 25, 2004
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Such a simple fix, thank you very much rvskin
     
  5. bonnmac

    bonnmac Well-Known Member

    Joined:
    Apr 26, 2003
    Messages:
    101
    Likes Received:
    0
    Trophy Points:
    16
    Same problem here on one of my servers. Resetting root pw doesn't fix it. Any other ideas?
     
  6. rvskin

    rvskin Well-Known Member
    PartnerNOC

    Joined:
    Feb 19, 2003
    Messages:
    400
    Likes Received:
    1
    Trophy Points:
    18
    check the file /root/.my.cnf.
    It will be something like this:

    [client]
    user="root"
    pass="yourdbpass"

    If you see any quotation(") just remove them, and it will be:

    [client]
    user=root
    pass=yordbpass
     
  7. bonnmac

    bonnmac Well-Known Member

    Joined:
    Apr 26, 2003
    Messages:
    101
    Likes Received:
    0
    Trophy Points:
    16
    Thanks. Much appreciated. Gave it a go, but I'm still getting:

    Welcome to phpMyAdmin 2.6.0-pl2


    Wrong username/password. Access denied.
     
  8. paolorulez

    paolorulez Guest

    ssh

    [root@host root]#killall mysqld
    [root@host root]#/usr/libexec/mysqld -Sg --user=root &
    [root@host root]# mysql
    Welcome to the MySQL monitor. Commands end with ; or g.
    Your MySQL connection id is 1 to server version: 3.23.41

    Type 'help;' or 'h' for help. Type 'c' to clear the buffer.

    mysql> USE mysql
    Reading table information for completion of table and column names
    You can turn off this feature to get a quicker startup with -A

    Database changed
    mysql> UPDATE user
    -> SET password=password(newpassword)
    -> WHERE user=root;
    Query OK, 2 rows affected (0.04 sec)
    Rows matched: 2 Changed: 2 Warnings: 0

    mysql> flush privileges;
    Query OK, 0 rows affected (0.01 sec)

    mysql> exit;
    [root@host root]#killall mysqld

    restart mysql
     
  9. bonnmac

    bonnmac Well-Known Member

    Joined:
    Apr 26, 2003
    Messages:
    101
    Likes Received:
    0
    Trophy Points:
    16
    That fixed it. Thank you!
     
Loading...

Share This Page