Database not showing special characters like é à.

ogamache

Registered
Oct 29, 2020
4
1
3
Montreal
cPanel Access Level
Root Administrator
Hi there, I am having an issue with my database, I just changed my database provider, I copied the database and It seems that the database won't show my special text correctly :

Capture d’écran 2020-10-29 103539.png

If you want to see the complete website, you can at Olivier Gamache (new)
I have the old database provider which is still working at Olivier Gamache (old)
Both of the websites are hosted on my CPanel server with the same config but not the same database, the database of the new website is on CPanel and the other one on Clevercloud.

Thank you in advance for your help
 

kodeslogic

Well-Known Member
Apr 26, 2020
87
27
93
IN
cPanel Access Level
Root Administrator
Compare the character set and collation of your databases and tables through phpMyAdmin between old and new providers.

  1. Log in to phpMyAdmin.
  2. Select your database from the list on the left.
  3. Click on "Operations" from the top set of tabs.
  4. In the Collation box, check if the value matches between old and new providers.
  5. Select your database from the list on the left.
  6. Click on "Operations" from the top set of tabs.
  7. In the Collation box, check if the value matches between old and new providers.
 

ogamache

Registered
Oct 29, 2020
4
1
3
Montreal
cPanel Access Level
Root Administrator
Thank you for your fast response!

I cannot access the operation tab but I can see in the databases tab that it says that the collation is utf8_general_ci in both of the databases
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
715
97
153
cPanel Access Level
Root Administrator
Hey there! Can you provide us with more details on what you mean when you say you've "changed the database provider" ? Does that mean you performed an update to the database version on the system, or you have migrated data?

The following two threads may also be helpful, as encoding issues always seem to be a tricky one to troubleshoot:

 

cPanelChris

Moderator
Staff member
Feb 16, 2020
38
4
8
Houston, TX
cPanel Access Level
Root Administrator
Hello @ogamache,

The operations tab should be available. Can you ensure that you have your database selected in phpMyAdmin? The operations tab will not appear if you have the information_schema database selected for example.

Additionally, collation can be set per table as well. As such, you may want to ensure that the collation is the same for the tables as well. This can also be done from the operations tab in the same way as for databases, but you'll have to first select the table instead of the database.

More information about this is available in the MySQL documentation linked below.

 

ogamache

Registered
Oct 29, 2020
4
1
3
Montreal
cPanel Access Level
Root Administrator
Hello @ogamache,

The operations tab should be available. Can you ensure that you have your database selected in phpMyAdmin? The operations tab will not appear if you have the information_schema database selected for example.

Additionally, collation can be set per table as well. As such, you may want to ensure that the collation is the same for the tables as well. This can also be done from the operations tab in the same way as for databases, but you'll have to first select the table instead of the database.

More information about this is available in the MySQL documentation linked below.

I cannot access the operation tab because of my user's permissions, this provider is free, that's why. But for the rest, I checked and both of the databases and they seem to be identical. Also, I exported the database and imported it.
I hope these informations can help.

Again, thank you all for your quick help :D