databases aren't showing up in cpanel but they are in WHM phpMyAdmin

bangweb

Registered
Sep 23, 2006
2
0
151
I have a web site on CP that the 3 databases aren't being listed in "MySQL Databases" under databases. But 2 of the 3 ARE showing up in CP/myPHPAdmin.

All 3 show up in WHM/myPHPAdmin !!!!

This all started when I reset the CPanel account password, i checked the box that said to sync with MySQL.

The databases fell out then.

When I went in and looked at .my.cnf the password was not the same as the CPanel account. BUT when I edited the file to match the CPanel account, I got an error when i tried to load CP/myPHPAdmin. When I set it back to the previous (but wrong password) the myPHPAdmin error went away.

Can someone give me exact steps to fix this?

I'm sure it's related to all the passwords as it was working before. Please give exact steps because I'm not that skilled with this stuff.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,241
363
Hello :)

Could you try resetting the account password again with the "Allow MySQL password change" option enabled? Check the cPanel error log when you do this to see if there are any specific errors logged:

Code:
/usr/local/cpanel/logs/error_log
You may also want to consider opening a support ticket with our staff so we can investigate further:

Submit A Ticket

Please post the ticket number here if you choose to do so.

Thank you.
 

rachelm

Well-Known Member
Verifed Vendor
Jan 26, 2005
94
1
158
Might want to also run /usr/local/cpanel/bin/setupdbmap

that will cause cpanel to update it's listing of databases and users for each account.
 

cPanelDavidN

Well-Known Member
Staff member
Dec 17, 2009
571
3
68
Houston, TX
cPanel Access Level
Root Administrator
Might want to also run /usr/local/cpanel/bin/setupdbmap

that will cause cpanel to update it's listing of databases and users for each account.
While that may be true most of the time, that's not the exact purpose of that script.

DO NOT RUN /usr/local/cpanel/bin/setupdbmap if you have Database Prefixing turned OFF! In fact, I would only run that script as a last resort (and never on a system with Prefixing OFF). That script should not be considered a 'repair' script (despite it's observed behavior in most environments).

If you have already run that script, and your system is working, then you should be fine. However, I wouldn't chance it...at least not without reading that Perl script and understanding everything it might do to the system and data.

If you haven't run that script, I'd really recommend you open a support ticket to get this issue resolved. cPanel's database abstraction layer can get complex; the Technicians can help repair your system, will report any new quirky behavior to Developers, and it's complementary too!

Regards,
-DavidN
 

ServerMascot

Member
Jan 17, 2011
13
1
53
You can try resetting the password from cPanel->Preferences->Change Password and tick on" Allow Mysql Password Change"