Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

DBD::mysql::db do failed

Discussion in 'General Discussion' started by wills, Jul 14, 2003.

  1. wills

    wills Well-Known Member

    Joined:
    Jan 29, 2003
    Messages:
    202
    Likes Received:
    1
    Trophy Points:
    168
    When I run any of the auto-installer links I get the following error (s):

    adding dbuser ****_osc1 DBD::mysql::db do failed: Can't find any matching row in the user table at /usr/local/cpanel/Cpanel/Mysql.pm line 720. We are installing in /home/****/public_html/test... ERROR 1045: Access denied for user: '****_osc1@localhost' (Using password: YES) Complete!

    Any ideas? this is after I updated Cpanel, not sure if it has any direct or in-direct effects.

    Input is appreciated (as long as it constructive).

    cPanel.net Support Ticket Number:
     
    #1 wills, Jul 14, 2003
    Last edited: Jul 14, 2003
  2. wills

    wills Well-Known Member

    Joined:
    Jan 29, 2003
    Messages:
    202
    Likes Received:
    1
    Trophy Points:
    168
    nevermind, I figured out the problem.

    cPanel.net Support Ticket Number:
     
  3. nitromax

    nitromax Well-Known Member

    Joined:
    Feb 12, 2002
    Messages:
    189
    Likes Received:
    0
    Trophy Points:
    316
    Would you mind sharing what you did to fix your problem? I having the same problem. Other posts I have read so far are not working.

    cPanel.net Support Ticket Number:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. nitromax

    nitromax Well-Known Member

    Joined:
    Feb 12, 2002
    Messages:
    189
    Likes Received:
    0
    Trophy Points:
    316
    Here is what I discovered on this issue. Account usernames that have hypens in them apparently cause problems in MySQL. The user I was having problems with had the username: the-spor

    Everytime I tried to install phpMyChat I got the 1045 error just as it basically shows above in the first post. But I tried setting it up on another account with out a hypen in the username and it worked fine.

    Many of the posts on this subject show: Access denied for user: 'root@localhost' (Using password: YES). Notice it's user ROOT.

    As you can see in the first post this hypen issue effects usernames, and so the error comes up as: Access denied for user: 'the-spor_chat1@localhost' (Using password: YES)

    It almost looks like the same error until you look closely.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #4 nitromax, Jul 21, 2003
    Last edited: Jul 21, 2003
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice