SOLVED Declare specific MySQL version during cPanel installation

Bretas

Active Member
PartnerNOC
Jun 10, 2018
27
5
3
Brazil
cPanel Access Level
Root Administrator
Hy, everyone!

We are migrating some customers to new boxes and we'd like to keep MySQL 5.6 running since 5.7 is not always backwards compatible in legacy applications. Currently cPanel installs MySQL 5.7 by default and there is no way to downgrade.

I've inspected the installation file (https://securedownloads.cpanel.net/latest) and there is no reference to the database server version there, so I'm assuming this is not possible.

Is it somehow possible to select the database version during installation? If not, would it be adequate for us to create a MySQL Profile connecting to a standalone MySQL 5.6 VM/container and then deleting the default profile (5.7) thereafter?

Thanks!