The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Dedicated IP nubmers not being allocated automatically

Discussion in 'General Discussion' started by handsonhosting, Nov 1, 2007.

  1. handsonhosting

    handsonhosting Well-Known Member

    Joined:
    Feb 17, 2002
    Messages:
    151
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Omaha, NE
    cPanel Access Level:
    Root Administrator
    Hey Folks,

    Not sure where to document this as I think it's a BUG, but wanted to see if anyone else is experiencing it and not just us;

    Basically we have a server which had the latest RELEASE version runnnig on it (11.15.0-C17827)

    We have packages setup on the account with the DEDICATED IP number selected.

    If you create the package directly in WHM it works with no problem - allocates the IP number and you're off and running.

    Using ModernBill it is set to use the PLAN BASED package - meaning pull it from the packages defined in cPanel.

    For some reason, in the latest release in cPanel this stopped working.

    Did not work in EDGE, RELEASE or CURRENT builds from 10/31/2007 at about 9pm PST.

    It DID work correctly in the STABLE release - 11.15.0-S16999

    Anyone else notice any issues on this before I submit it as a bug report?
     
  2. handsonhosting

    handsonhosting Well-Known Member

    Joined:
    Feb 17, 2002
    Messages:
    151
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Omaha, NE
    cPanel Access Level:
    Root Administrator
    For those interested (and I would have thought there were a few people here using modernbill with the latest cPanel builds), I submitted a bug report on 11/1/2008 and received a status on 11/12/1007;

    http://bugzilla.cpanel.net/show_bug.cgi?id=6063

    Basically cPanel says it's somethign that Modernbill will be implementing to get around the issue.

    I contacted Modernbill, and they knew nothing about it.
     
  3. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    It's a two-fold issue:

    1) On the cPanel side there were changes made that made the XML-API not work as documented

    2) On the ModernBill side there were calls made via the XML-API that were not in accordance with the documentation
     
Loading...

Share This Page