The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Default Account - :blackhole: / :fail: not working correctly

Discussion in 'General Discussion' started by rinty, Nov 17, 2002.

  1. rinty

    rinty Well-Known Member

    Joined:
    May 31, 2002
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    Hi,

    We are currently having a problem with CPanel where if you set Default Account to :fail: the main account email box does not receieve email...

    anyideas why this is happening?
     
  2. rinty

    rinty Well-Known Member

    Joined:
    May 31, 2002
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    But it says only unrouted mail wont get through.. so ???
     
  3. scsiman

    scsiman Registered

    Joined:
    Jan 29, 2003
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I agree it says all unrouted email.

    Is there a way to fix this, as it is broken. If I have a main account of bobby@mydomain.com and I set the default address to :fail: it should allow mail to bobby@mydomain.com and reject anything else that does not exist on the server.

    IE:

    Main Account: bobby
    Other email: webmaster@mydomain.com
    another one: suzzy@mydomain.com
    another one: tim@mydomain.com

    If I set Default Address to :fail: then....

    Emails to webmaster, suzzy, tim, AND bobby should pass through since they exist, but mail to anything_else@mydomain.com should be bounced ( if using :fail: ) or eaten ( if using :blackhole )
    This is the way I read the documentation for CPanel.
     
  4. JustinK

    JustinK Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    251
    Likes Received:
    0
    Trophy Points:
    16
    The problem comes when someone doesn't want mail to the main username at all. As it is now, it works great for those people which were complaining before since they didn't have an option for that.

    You can manually edit the alias file for the domain (/etc/valiases/theirdomain.com) and add the following line in to fix that:
    mainuser@theirdomain.com: mainuser
     
  5. scsiman

    scsiman Registered

    Joined:
    Jan 29, 2003
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    That's understandable, the documentation should be fixed to reflect this.
     
Loading...

Share This Page