The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

default address blackhole not working

Discussion in 'General Discussion' started by salvatore333, Jul 1, 2004.

  1. salvatore333

    salvatore333 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    customers default email address is filled with emails not being blocked by blackhole. does anyone know how to block emails to the default address?

    thank you
     
  2. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,367
    Likes Received:
    5
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Make sure you have :blackhole: with the colon on either side. Also /dev/null might work.
    We have been using :blackhole: for quite some time and it works well.
     
  3. Slav

    Slav Well-Known Member

    Joined:
    Oct 28, 2002
    Messages:
    144
    Likes Received:
    0
    Trophy Points:
    16
    I have noticed that lately people that have :blackhole: setup on the default account have all the mail fail, even the routed mail , if the customer removes the blackhole in the default account everything start sto flow again.. Weird stuff.
     
  4. jrehmer

    jrehmer Well-Known Member

    Joined:
    Apr 10, 2003
    Messages:
    287
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Denver, CO
    I've noticed something similar to this as well. People tell me they send me e-mails, but certain ones never arrive to my server. No log of it, or attempted delivery. Then take out the :blackhole: for the default user on my domain and all those people who couldn't e-mail me before can.

    Although some mail still flows through even with :blackhole: I know from personal correspondence that certain people's mail does not get delivered, why I do not know.
     
  5. Slav

    Slav Well-Known Member

    Joined:
    Oct 28, 2002
    Messages:
    144
    Likes Received:
    0
    Trophy Points:
    16
    Yes i had it now for ytwo clients and i tested it and i can confirm this.
    The dissapointing issue is that hardly anyone ever answers the bugs we submit. it salike the work on cpanel has virtually sized. But theres not much we can do about it. :)

    SLav
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    So you have logged these in the cPanel bugzilla?
     
  7. curtgranger

    curtgranger Registered

    Joined:
    Oct 3, 2003
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Birmingham AL USA
    I'm having the same problem. I changed my default to :blackhole: and I couldn't get test emails I was sending from other external email accounts. I also tried /dev/null. Once I set it back to my account's user name the emails went through. Reported it to my hosting co.'s tech support but they weren't able to resolve it (yet).

    I also found where it has been logged in Cpanel BugZilla - http://bugzilla.cpanel.net/show_bug.cgi?id=1037
     
    #7 curtgranger, Aug 14, 2004
    Last edited: Aug 14, 2004
  8. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    What OS are you on?
     
  9. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Do you have the same problem if you use :fail: instead of :blackhole: ?
     
  10. Slav

    Slav Well-Known Member

    Joined:
    Oct 28, 2002
    Messages:
    144
    Likes Received:
    0
    Trophy Points:
    16
    yes i have
     
  11. Slav

    Slav Well-Known Member

    Joined:
    Oct 28, 2002
    Messages:
    144
    Likes Received:
    0
    Trophy Points:
    16
    we are on red hat 9
     
  12. Slav

    Slav Well-Known Member

    Joined:
    Oct 28, 2002
    Messages:
    144
    Likes Received:
    0
    Trophy Points:
    16
    i have not tired fail as yet sorry
     
  13. kofi

    kofi Well-Known Member
    PartnerNOC

    Joined:
    Feb 3, 2004
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    We have the same problem on RHEL
     
  14. Jeff75

    Jeff75 Well-Known Member

    Joined:
    Apr 11, 2003
    Messages:
    555
    Likes Received:
    0
    Trophy Points:
    16
    Anybody know why :blackhole: does not keep email from being received?

    I have an account who has set up the following mail filters and set their fallover account to ":blackhole:". For some reason they keep receiving email in their main inbox account.

    Here's an example of one of the emails that he still received even though the filter is set up:

    Subject: Mail delivery failed: returning message to sender
    To: login@name.server.com

    Can somebody tell me why they are still receiving bounced emails even though the filters are set up and the fallover is set to :blackhole:?
     
    #14 Jeff75, Sep 13, 2004
    Last edited: Sep 13, 2004
  15. dxer

    dxer Well-Known Member

    Joined:
    Sep 9, 2002
    Messages:
    295
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Europe
    Iam just about now fighting this issue. Opened a Ticket at cPanel but they tried some things but nothing solved yet.
    Iam at RHEL 3 and cPanel 9.9.1. S50.

    When I set :blackhole: normal messages are not coming as well as unrouted. The same thing is with :fail: no such address here.
    Just about when I remove any of this, flood of spam starts right away and it could easily fill inbox with hundreds of e-mail in couple of minutes.
    I tried to enable SpamAssasin but then he sents all this warnings of possible spam so this is very annoying too.

    Any new idea how to fix this ?
     
  16. lloyd_tennison

    lloyd_tennison Well-Known Member

    Joined:
    Mar 12, 2004
    Messages:
    698
    Likes Received:
    1
    Trophy Points:
    18
    Have any of you vastly changed exim.conf? I discard, fail, blackhole, whtever depending on the value -at least 25,000 pieces a day - and more when I include clam and some dnsrbl listings, especially for cable/dsl/broadband.

    I am running on Redhat, but on current relaeses of Cpanel - but have never had that problem - even when running on releases that old.

    Why do you not try saving your exim.conf and then rebuild from the default and try testing again?
     
  17. kofi

    kofi Well-Known Member
    PartnerNOC

    Joined:
    Feb 3, 2004
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    Are they targeting a specific domain?

    If so you can edit /etc/valiases/domain.com

    And remove the *|: line
     
Loading...

Share This Page