The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Default address :fail: and returned mail

Discussion in 'E-mail Discussions' started by Blue|Fusion, Jul 23, 2005.

  1. Blue|Fusion

    Blue|Fusion Well-Known Member

    Joined:
    Sep 12, 2004
    Messages:
    378
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Cleveland, Ohio
    Hello,

    I would assume this is not normal but maybe Chirpy, the guru, can comment on this... ;)

    I just recently started getting a ton of spam to the main domain email account. I noticed most, if not all were dictionary attacks so I change the default address from the username to :fail: and enabled SpamAssassin.

    After 3 days of recieving no mail, I started to wonder if with the recent cPanel updates and words going around about the mail issues, maybe something is up. After some testing I found that I can send and recieve from accounts created in cPanel's Mail Account Manager, however, the main domain account can not recieve email. The same account can send email no problem, however. I changed the default address from :fail: to the username again, and bingo, worked like a charm. I still don't want to recieve all that garbage though, and want to keep it set to :fail:, but for the mean time am unable to.

    Here is any info I can think of providing and if you need more, let me know. And I can't look at the moment, but any bugzillas already opened I should submit this to?

    Return reciept when default address set to :fail: (and again, this is only for the main cpanel email account for the domain):
    Exim log of a rejected message while default address was set to :fail: and a message that went through with the default address set to the username:
    While :fail: was set as the default address, I did all of the following:
    Uninstalled cPanel Pro
    /scripts/updatenow
    /scripts/upcp --force
    /scripts/eximup --force
    /scripts/mailperms
    Reinstalled cPanel Pro

    root@saturn [~]# cat /etc/redhat-release;/usr/local/cpanel/cpanel -V;rpm -q exim
    Red Hat Enterprise Linux ES release 3 (Taroon Update 5)
    10.4.0-CURRENT_154
    exim-4.52-7_cpanel_smtpctl_av_rewrite_mm2_mmmtrap_exiscan_md5pass

    I only checked this on this one box for now, and will be unable to check others until later unless someone has any other input confirming my problems are related to cPanel. And I also only checked this one account which needed this fixed ASAP. When I get home later this evening I can check more.

    Also if it is any relevance, the SMTP Tweak is enabled allowing connections to localhost.
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    This is actually normal behaviour for the main account. If the Default Address is set to anything other than the main account, e.g. :fail: you need to either:

    1. Create a new Mail account called account@domain.com and use that to login into instead of account

    or

    2. Create a forwarder for account@domain.com and point it to account@hostname.server.com
     
  3. Blue|Fusion

    Blue|Fusion Well-Known Member

    Joined:
    Sep 12, 2004
    Messages:
    378
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Cleveland, Ohio
    Thanks alot Chirpy.

    So before I go ahead and screw things up let me make sure I have this right...

    I can set Default Address to :fail: and create a forwarder for username@domain.com to forward to username@hostname.serverdomain.com and it will work properly?

    And is there any way to have such a forwarder setup for each account (atleast new), or would I have to create a bugzilla for an enhancement (not sure if I will anyway)?

    Thanks, Chirpy for the intel!
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Yup, should do.
    You'd need to script that to add the forwarder to the domains /etc/valiases/domain.com file.
     
Loading...

Share This Page