The Community Forums

Interact with an entire community of cPanel & WHM users.
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Default Address overrides Account Level Filters

Discussion in 'E-mail Discussions' started by philpem, Jun 24, 2009.

  1. philpem

    philpem Member

    Joined:
    Aug 12, 2005
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Version 11.24.4-RELEASE, build 36167

    I'm trying to add a filter to forward everything that's sent to "myusername.foo@mydomain.me.uk" (where 'foo' can be any alphanumeric sequence). To do this, I've set up an account level filter:

    Code:
    Rules:
    [To] [Begins with] [philpem.]
    
    Actions:
    [Redirect to email] [<my email here>]
    
    I also have Default Address set to ":fail No such person here"

    If I send mail from the server to 'myusername.foo@mydomain.me.uk', then the mail is passed along successfully.
    If I attempt to send that same email from (say) Gmail to the same address, it's bounced with the error I set under Default Address (550 No such person here).
    If I run a mail trace, I get one red-bordered box:
    Code:
    virtual_aliases via virtual_aliases router forced address failure
    What is going on here? All I want is for mail with a given prefix to go through to my main email account.

    I've been into WHM and re-saved the Exim config, but this hasn't made any difference. I'm tempted to force a cPanel and Exim upgrade but this seems a bit of a "sledgehammer to crack a nut" solution to the problem...

    Can anyone offer any assistance with this issue?

    Thanks,
    Phil.
     
Loading...

Share This Page