The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Default Address Settings Don't Work

Discussion in 'General Discussion' started by smachol, Jul 27, 2007.

  1. smachol

    smachol Well-Known Member

    Joined:
    Oct 19, 2001
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    My problem is that when I set the Default Address in cPanel to :fail: or :blackhole: NO mail gets through - even mail to the existing legitimate acccounts.

    Using cPanel Pro 1.0 (RC1)
     
  2. DaveUsedToWorkHere

    DaveUsedToWorkHere Well-Known Member

    Joined:
    Dec 28, 2001
    Messages:
    689
    Likes Received:
    1
    Trophy Points:
    18
    What cPanel build are you using? Have you checked the exim mainlog for that domain's messages or contacted your host if you are a domain owner?
     
  3. smachol

    smachol Well-Known Member

    Joined:
    Oct 19, 2001
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Build 11.6.0-RELEASE 15076

    I have a dedicated server.

    Unfortunately I have no idea what I am supposed to check the exim mainlog for. The question is why don't those options work as per the documentation? Is it a problem with this version of cPanel?

    Thanks for replying so quickly. :)
     
    #3 smachol, Jul 27, 2007
    Last edited: Jul 27, 2007
  4. DaveUsedToWorkHere

    DaveUsedToWorkHere Well-Known Member

    Joined:
    Dec 28, 2001
    Messages:
    689
    Likes Received:
    1
    Trophy Points:
    18
    I haven't heard of this as a repeated problem so some investigation of the cause will be necessary. You can run from the command line as root:

    Code:
    tail -f /var/log/exim_mainlog
    while sending messages to see if you get any errors, or you can open a support ticket with our staff and they will help investigate.
     
  5. smachol

    smachol Well-Known Member

    Joined:
    Oct 19, 2001
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    Should I set :fail: or :blackhole: first? Any preference? I can''t afford to have all my legitimate email not come through for more than a minute or so. This is my job.
     
  6. DaveUsedToWorkHere

    DaveUsedToWorkHere Well-Known Member

    Joined:
    Dec 28, 2001
    Messages:
    689
    Likes Received:
    1
    Trophy Points:
    18
    :fail: is definitely recommended as :blackhole: processes the message and then discards it. :fail: will reject the message before any processing is done.
     
  7. smachol

    smachol Well-Known Member

    Joined:
    Oct 19, 2001
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    Rejected:

    2007-07-27 12:08:41 H=mxl144v247.mxlogic.net (p01c11m006.mxlogic.net) [208.65.144.247] F=<xxxxx@yahoo.com> rejected RCPT <xxxxx@yyyy.com>:
     
  8. smachol

    smachol Well-Known Member

    Joined:
    Oct 19, 2001
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    And 'Submit Support Request' does not work. There are no links or options other than 'Go Back' after going to that page.
     
  9. DaveUsedToWorkHere

    DaveUsedToWorkHere Well-Known Member

    Joined:
    Dec 28, 2001
    Messages:
    689
    Likes Received:
    1
    Trophy Points:
    18
    Submit Support Request in cPanel links to a support system for your host (if set up). Please submit at support request at cpanel.net (https://tickets.cpanel.net/submit/index.cgi?reqtype=tickets).


    It does appear to be rejecting the mails but without more server specific info, it'll be hard to troubleshoot.
     
  10. smachol

    smachol Well-Known Member

    Joined:
    Oct 19, 2001
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    *sigh*

    It requires a 'support access number'. What do I enter?
     
  11. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    In WHM -> Support -> Support Center you will see a Support Access Number at the bottom, you should enter that. If you do not have access to that portion of WHM, you should have your web hosting provider contact us on your behalf.
     
  12. smachol

    smachol Well-Known Member

    Joined:
    Oct 19, 2001
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    Thanks again.
     
Loading...

Share This Page