The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Default character set for new databases

Discussion in 'General Discussion' started by remik, Aug 14, 2007.

  1. remik

    remik Guest

    Hi.
    Can one change default character set used for NEW databases created by cPanel?
    I know I could change the default one in my.cnf, but then it corrupts data returned by my clients databases - their websites use old charsets.

    The idea my friend came up with is to find, where cPanel creates the DB and change the SQL statement to something like this:
    CREATE DATABASE `name` DEFAULT CHARACTER SET utf8 COLLATE utf8_polish_ci;

    I looked into /scripts, but only found DELETE DATABASE statement.

    Any help appreciated.

    Remik
     
  2. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    It would be in /usr/local/cpanel/Cpanel/Mysql.pm. but will be overwritten by updates.

    If possible, change it at the table level, or change it after the DB is created, but before any data is inserted.
     
  3. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,449
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:

    Hate to hijack a thread, but you mention Mysql.pm so I thought I might ask here. In cpanel/logs/error_log I found several of these today.


    But only for a handful of users. Any idea what this is about?
     
  4. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider

    Its only an info level messages

    Tue Aug 14 01:50:51 2007 info

    safe to ignore.


    It means that its not setting the users mysql password to the reseller's password since you were logged in to the account as root or the reseller
     
  5. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,449
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Got it. Thanks Nick. :)
     
Loading...

Share This Page