Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Default email addresses do not work

Discussion in 'E-mail Discussions' started by wills, Sep 22, 2003.

  1. wills

    wills Well-Known Member

    Joined:
    Jan 29, 2003
    Messages:
    202
    Likes Received:
    1
    Trophy Points:
    168
    WHM 8.2.0 cPanel 8.2.0-E27
    RedHat - WHM X v2.1

    none of the deafult email accounts are working. I can't send or receive. Well I can receive but it keeps asking for the password. Sending is defeintely out of the question.

    OH yeah, when I send an email I get unroutable address error back.

    Any ideas?

    cPanel.net Support Ticket Number:
     
  2. wills

    wills Well-Known Member

    Joined:
    Jan 29, 2003
    Messages:
    202
    Likes Received:
    1
    Trophy Points:
    168
    bump: anyone?

    cPanel.net Support Ticket Number:
     
  3. techark

    techark Well-Known Member

    Joined:
    May 22, 2002
    Messages:
    280
    Likes Received:
    0
    Trophy Points:
    316
    Go back to version 7 stable.

    I tried 8 on 3 machines lost emai lon all of them went back to stable version 7 and is well again.

    Nick you got some serious work to do before you turn that beast lose on us as stable.

    cPanel.net Support Ticket Number:
     
  4. wills

    wills Well-Known Member

    Joined:
    Jan 29, 2003
    Messages:
    202
    Likes Received:
    1
    Trophy Points:
    168
    Can I change the update preference and rollback to 7 without causing more havoc? I just don't want to inconvenience my clients any more then they are :)

    cPanel.net Support Ticket Number:
     
  5. imagic

    imagic Well-Known Member

    Joined:
    Jan 16, 2003
    Messages:
    156
    Likes Received:
    0
    Trophy Points:
    166
  6. wills

    wills Well-Known Member

    Joined:
    Jan 29, 2003
    Messages:
    202
    Likes Received:
    1
    Trophy Points:
    168
    I did try /usr/local/cpanel/bin/checkdefaultaddys --force actually. Still gives me the same results, which is unroutable address.

    Will

    cPanel.net Support Ticket Number:
     
  7. wills

    wills Well-Known Member

    Joined:
    Jan 29, 2003
    Messages:
    202
    Likes Received:
    1
    Trophy Points:
    168
    Reply from the folks at Cpanel support:

    Yes, you will need to edit the default address for these domains. You can do one of 2 things:

    edit the the files in the /etc/valiases directory; change the wildcard entry so it looks like this:
    *:username
    instead of
    *:username@domain.com
    (you could possibly write a script to do this)

    Or you can go into the client's control panel, go into default address and reset it to go to just the username, rather than the entire email address.

    If you have further questions, please let us know. Thanks.


    cPanel.net Support Ticket Number:
     
  8. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,453
    Likes Received:
    12
    Trophy Points:
    148
    cPanel Access Level:
    DataCenter Provider
    Do you have a support ticket number?

    cPanel.net Support Ticket Number:
     
  9. wills

    wills Well-Known Member

    Joined:
    Jan 29, 2003
    Messages:
    202
    Likes Received:
    1
    Trophy Points:
    168
    Yes I do.

    oh yes, I Sure do: 24138 :) currently working with Shanna.

    cPanel.net Support Ticket Number: 24138
     
  10. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,453
    Likes Received:
    12
    Trophy Points:
    148
    cPanel Access Level:
    DataCenter Provider
    Re: Yes I do.

    # /scripts/updateuserdomains
    == WORKAROUND ENABLED ==
    Serious Problem -- This should never happen!!
    The hostname (*hostname removed*) is owned by the user *user removed*
    == WORKAROUND ENABLED ==

    It appears that there was a subdomain created with the same name as the hostname. Newer releases prevent this from happening. Removing the subdomain should resolve the problem. I've updated the userdomains script to ignore the hostname when it sees it in a cpanel users file.

    cPanel.net Support Ticket Number:
     
  11. wills

    wills Well-Known Member

    Joined:
    Jan 29, 2003
    Messages:
    202
    Likes Received:
    1
    Trophy Points:
    168
    Ah, so it was self induced :) as always.

    Thank you for the prompt fix!

    cPanel.net Support Ticket Number:
     
  12. maxime

    maxime Member

    Joined:
    Aug 13, 2001
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    301
    Hi,

    I have just identified another cause for the "unrouteable address" message.

    On some of my (very old) accounts, the /etc/valiases/domain.com file contained some addresses with a space before the column. Example:

    test@domain.com : test@domain2.com

    When corrected to

    test@domain.com: test@domain2.com

    this solved the problem...

    Hope this helps other people.

    Maxime

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page