The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Default email and domain problem between two cPanel versions

Discussion in 'E-mail Discussions' started by hitrss.com, Jun 2, 2006.

  1. hitrss.com

    hitrss.com Member

    Joined:
    Aug 23, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I have a problem with default email account and main domain I have on my cpanel account.

    On my old server I had cPanel 10.8.0 release 27
    and on my new one I have 10.8.2 release 83

    I have moved my account from my old server to the new one and this is what happened:

    let's say my account name is 'myaccount' and my default domain name is 'mydomain.com'

    On my old server I had an additional mailbox set up called: myaccount@mydomain.com and although I had the default email account set up by cPanel, all email would go to this manually set up mailbox.

    additonally in 'Default Address Maintenance' section for domain 'mydomain.com' I had set up: ':fail: no such address here'

    Once I moved to the new server, all mail sent to myaccount@mydomain.com goes to the DEFAULT mailbox, not to the one created by me: 'myaccount@mydomain.com'... and what's more, in the 'Default Address Maintenance' section for my domain 'mydomain.com' I have 'myaccount' instead of ':fail: no such address here' and it won't let me change that!

    Please help, I want to have the address 'myaccount@mydomain.com' work, and don't want to login to my default mailbox with my cpanel password. Why it used to work and now it doesn't work anymore?

    Any help would be appreciated, thanks!

    Regards,

    - Michael
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    As you're surmized, the problem is that you cannot set the Default Address to :fail: which is what you need to get resolved. If you're the server admin, you can do this manually by editing /etc/valiases/domain.com and setting:

    *: :fail:

    Then email will be redirected to the virtual account account@domain.com instead of the linux account.

    If you're not the server admin, you'll have to ask your web hosting provider to sort this out.
     
  3. hitrss.com

    hitrss.com Member

    Joined:
    Aug 23, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the info. I am the server admin.

    It appears I didn't even have the file: domain.com in the /etc/valiases/ directory.

    Well, I created it and now when I log in to the Main / Default Adress section, it shows the "fail" option with this domain. So far so good.

    But email going to myaccount@mydomain.com is still going to the Default Account.

    What's more, I cannot log in to the virtual account "myaccount@mydomain.com" I created. I mean, I cannot read mail from this virtual account, I can only read mail from the main account.

    Again, on my old server I could log in to the virtual account and email would go to the virtual account instead of the default one.

    Please help.

    - Michael
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Try running the following which may help:

    /scripts/updateuserdomains
    /scripts/mailperm
     
  5. hitrss.com

    hitrss.com Member

    Joined:
    Aug 23, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for your info, but I couldn't find the problem still... when I ran the /updatedomains script, I got this error:

    == WORKAROUND ENABLED ==
    Serious Problem -- This should never happen!!
    The hostname (mydomain.com) is owned by the user myaccount
    == WORKAROUND ENABLED ==

    And than I realised the difference between the old host and the new one!

    In the old host, my hostname was: host.mydomain.com
    and in my new one: mydomain.com (without the "host" subdomain)

    so when I changed the host in WHM from mydomain.com to host.mydomain.com everything worked like a charm!

    Why? Because mail sent to myaccount@mydomain.com would go to the vitual user, as the default address has changed to myaccount@host.mydomain.com now - so there was no address overlapping anymore!

    Glad I figured this out and thanks for helping me here too,

    Great forum,

    Best regards,

    - Michael
     
Loading...

Share This Page