The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Default error page domain.com/cgi-sys/defaultwebpage.cgi

Discussion in 'General Discussion' started by musti19, Jun 27, 2013.

  1. musti19

    musti19 Well-Known Member

    Joined:
    Jan 20, 2013
    Messages:
    103
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Hello,
    i created a custom 404 Page in cPanel(User),
    but if i try to open a non exist subdomain, it redirects me to
    the default page of the server:
    domain.com/cgi-sys/defaultwebpage.cgi

    instead of the created custom error page.(from user)

    How can i fix this ?

    thank you
     
  2. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    Are you sure you mean subdomain?
    If the subdomain does not exist you should get an error like this (in chrome):
    "Oops! Google Chrome could not find <youd non-existing subdomain here>"
     
  3. Serra

    Serra Well-Known Member

    Joined:
    Oct 27, 2005
    Messages:
    213
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    Florida
    Is this a sub domain that DID exist, and that you accessed, but does not now exist? Then it might just be a cache issue.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,808
    Likes Received:
    667
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    The page should not load at all if the subdomain does not exist. A custom 404 would not apply because the subdomain would not exist in the Apache configuration file. You may experience this issue if you have a subdomain that is not created in cPanel, yet resolves to an IP address hosted on the server.

    Thank you.
     
Loading...

Share This Page