SOLVED Default error page on main IP

rinchen

Member
Nov 15, 2017
10
2
3
Australia
cPanel Access Level
Root Administrator
Hi
I am not sure whether I have installed cPanel correctly.

I am using CentOS 7 on VPS and assigned static ip address on it.

The issue is that I keep getting the default error page on my main ip address although I can successfully login to WHM and cPanel.

Is the issue related to configuration of cPanel or something else?

thank you for help in advance.
 

SysSachin

Well-Known Member
Aug 23, 2015
604
48
28
India
cPanel Access Level
Root Administrator
Twitter
Can you check.

Main IP of server is "shared one" which is supposed to show default page.
To access domain with IP then add one more IP to server and assign it to domain from WHM > change site IP address. To access web site on shared IP is http://IP-address of server/~cpanelusername.

Another option is to ssh server and edit apache config and remove first virtual host entry of hostname. But any update to apache will revert changes so best way is add one more IP and assign to site.

.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,215
363
Hello,

It's normal to see the default cPanel page when opening the IP address directly in a web browser. You should create new accounts if you'd like to add content that will appear on domain names.

Thank you.
 

rinchen

Member
Nov 15, 2017
10
2
3
Australia
cPanel Access Level
Root Administrator
Thank you Michael and Sachin,

I did created an account however it would not load the HTML file I created to test the page.

maybe its because of the single IP address I assigned to the server but my dedicated IP for the server should work isn't it? In the mean time I will talk to my boss regarding additional IP address.

I think my IP assigned to the server is not resolving properly. Could you guide me on that please.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,215
363
Hello,

That's correct. Also, you can use "WHM >> Web Template Editor" if you'd like to edit the default page.

Thank you.