SOLVED Default home directory name issue

Sajawal

Active Member
Sep 10, 2020
26
1
3
Pakistan
cPanel Access Level
Root Administrator
Hi,

I have a server with cPanel v98.0.6 build and when I create an account on it and the account is being created on /home2 instead of /home even though /home is selected in the Basic WebHost Manager® Setup option but still, accounts are being created on /home2.

Regards,

Sajawal
 
Last edited by a moderator:

quietFinn

Well-Known Member
Feb 4, 2006
1,329
141
193
Finland
cPanel Access Level
Root Administrator
Hi,

I have a server with cPanel v98.0.6 build and when I create an account on it and the account is being created on /home2 instead of /home even though /home is selected in the Basic WebHost Manager® Setup option but still, accounts are being created on /home2.
The next setting:
"Additional home directories matching the following value will also be used for new home directory creations. (Leaving this value blank disables the feature.) Only mount points are considered. This option only takes one value.".
If you leave that value blank WHM should not use directory /home2.
 
  • Like
Reactions: cPRex

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,491
1,008
313
cPanel Access Level
Root Administrator
It's also important to note this text as well:

"Enter the location where you wish for new users’ home directories to be created. By default all directories matching the "Home Directory Prefix" are checked for available disk space and the directory with the most free space will be used."

so if /home2 has more available space than /home, that could be your issue.
 

Sajawal

Active Member
Sep 10, 2020
26
1
3
Pakistan
cPanel Access Level
Root Administrator
It's also important to note this text as well:

"Enter the location where you wish for new users’ home directories to be created. By default all directories matching the "Home Directory Prefix" are checked for available disk space and the directory with the most free space will be used."

so if /home2 has more available space than /home, that could be your issue.
Yes, you are right thanks for the help, the issue is resolved now by setting empty on the below option.

" Additional home directories matching the following value will also be used for new home directory creations. (Leaving this value blank disables the feature.) Only mount points are considered. This option only takes one value."