The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

defaultwebpage.cgi on all sites created

Discussion in 'General Discussion' started by webstuff, Jul 20, 2011.

  1. webstuff

    webstuff Well-Known Member

    Joined:
    Jul 19, 2011
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    everytime I add a new site I get the defaultwebpage.cgi my nat was on earlier today but I have taken it off. Any suggestions or ideas what could be causing the problem?

    ( when i setup the cpanel software at first I did put the some of the ip address's in the incorrect spots, but it was fixed according to cpanel..) I just still get the dang default web page

    Email works wonderfully... :)
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    When a site is being added, is the correct IP listed in /usr/local/apache/conf/httpd.conf as well as in /var/named/domain.com.db file (where domain.com is the domain name)?

    If the correct IP is being used for the VirtualHost entry and DNS zone, then please try restarting Apache and see if the site works then (you might be cached and need to check in a proxy such as proxify.net to see if that did work to get the site resolving properly):

    Code:
    /etc/init.d/httpd restart
     
  3. webstuff

    webstuff Well-Known Member

    Joined:
    Jul 19, 2011
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    ok I just heard back from cpanel... I'm at a complete loss though because the other people are telling me that NAT is disabled on my router....



    I'm sorry, but NAT does not appear to be disabled. The IP address on your server (192.168.x.x) is still a priviate IP, rather than a public one. A "non-NAT configuration" means that the public IP address (in this case 71.xxx.xx.xxx) is directly assigned to the server. This will need to be corrected.
     
  4. webstuff

    webstuff Well-Known Member

    Joined:
    Jul 19, 2011
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    Ok.. I think the information I have been given has been completely wrong.. Ok.. First you have your modem ( in brigde modem - suggested by the isp ) Then you have what? A switch a router? (what type of router or switch or whatever you would call it the box thingy in the middle would you suggest buying? ) What assigns the external ip? I am being told that the nat is off.. My static ip is in the router.. then it points to a local server 192.xx.xx.xx on the network.. Am I missing something?
     
    #4 webstuff, Jul 20, 2011
    Last edited: Jul 20, 2011
Loading...

Share This Page