Deleted account (and its Zone), now won't let me park the domain

smatt

Active Member
Apr 28, 2016
26
2
3
london
cPanel Access Level
Root Administrator
Hi all,

I'm tidying up some defunct accounts and domains.

I deleted an account off one server, did not keep it's dns zones. On second server, when I try to add the domain as an alias to another account it gives me the error:

There was an error when the system attempted to create the alias. Park::park(example.com) failed: (XID v35jw5) Sorry, the domain is already pointed to an IP address that does not appear to use DNS servers associated with this server. Please transfer the domain to this servers nameservers or have your administrator add one of its nameservers to /etc/ips.remotedns and make the proper A entries on that remote nameserver.
The two servers use clustered nameservers (ns1 and ns3 are these 2 servers, ns2 is a separate VM). When I look in the zone list, none of them have the domain listed.

The domain is has ns1 and ns2 for nameserver entries with the registrar. I have added ns3 and am waiting for propagation to see if that fixes but I've done this exact procedure with a couple of other domains that don't use ns3 and not had a problem.

Is there something else / somewhere else that is blocking it?

Edit: Domain was in clientHold status (oops..). Verified and problem resolved.
 
Last edited:

smatt

Active Member
Apr 28, 2016
26
2
3
london
cPanel Access Level
Root Administrator
Why when the servers are part of a nameserver cluster?

I have other domains that have only have ns1 and ns2 with the registrar but they are parked on this server fine.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,205
363
There was an error when the system attempted to create the alias. Park::park(example.com) failed: (XID v35jw5) Sorry, the domain is already pointed to an IP address that does not appear to use DNS servers associated with this server. Please transfer the domain to this servers nameservers or have your administrator add one of its nameservers to /etc/ips.remotedns and make the proper A entries on that remote nameserver.
Hello,

Please browse the "Remote Name Server IPs" tab in "WHM >> IP Functions >> Configure Remote Service IPs" and ensure the IP addresses of your remote name servers are added. The configuration file associated with this option is located at /etc/ips.remotedns (note it's only created manually, or after adding the first IP address to the interface in WHM).

Thank you.
 

smatt

Active Member
Apr 28, 2016
26
2
3
london
cPanel Access Level
Root Administrator
Hi Michael, I've done as you suggested but no change, I still can't add it.

I've double checked the zones on the cluster, no entries anywhere for the domain and have double checked the nameservers for the domain, they are pointing to my own.

Any other suggestions please?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,205
363
Domain was in clientHold status. oops, I didn't notice. Sorted now. Thanks for the help Michael.
I'm happy to see you were able to determine the cause of the problem. Thank you for updating us with the outcome.