The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

DENY_IP_LIMIT csf v4.62

Discussion in 'General Discussion' started by crazyaboutlinux, Apr 14, 2009.

  1. crazyaboutlinux

    crazyaboutlinux Well-Known Member

    Joined:
    Nov 3, 2007
    Messages:
    938
    Likes Received:
    0
    Trophy Points:
    16
    HI

    we have installed CSF firewall ( ConfigServer Security & Firewall - csf v4.63)
    when i check csf server check security option it showing me error like this

    DENY_IP_LIMIT sanity check WARNING DENY_IP_LIMIT = 0. Recommended range: 10-1000 (Default: 100)

    how do i resolve this issue & what is Recommended range : 10-1000
     
    #1 crazyaboutlinux, Apr 14, 2009
    Last edited: Apr 14, 2009
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,480
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    This has nothing to do with cPanel. For support of this product you'd need to visit the CSF forums.

    Basically that setting is for the number of IPs in your blocked list. Once it reaches that limit the oldest blocked IPs are removed.

    I personally have mine set to 150, if that helps.
     
  3. big_bull

    big_bull Well-Known Member

    Joined:
    Nov 19, 2006
    Messages:
    150
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    just go to /etc/csf/csf.conf and search for DENY_IP_LIMIT and change the value....
     
  4. crazyaboutlinux

    crazyaboutlinux Well-Known Member

    Joined:
    Nov 3, 2007
    Messages:
    938
    Likes Received:
    0
    Trophy Points:
    16
    oldest blocked ip will not be removed that is not good idea what to do for that

    let me set this limit also
     
  5. thewebhosting

    thewebhosting Well-Known Member

    Joined:
    May 9, 2008
    Messages:
    1,201
    Likes Received:
    1
    Trophy Points:
    38
    Go to WHM -> plugins -> configserver security & firewall -> Firewall configuration.

    Please check if you have set up DENY_IP_LIMIT between 10 to 100.
     
  6. crazyaboutlinux

    crazyaboutlinux Well-Known Member

    Joined:
    Nov 3, 2007
    Messages:
    938
    Likes Received:
    0
    Trophy Points:
    16
    Thanks for your details path

    but Infopro has already inform in this thread
     
  7. thewebhosting

    thewebhosting Well-Known Member

    Joined:
    May 9, 2008
    Messages:
    1,201
    Likes Received:
    1
    Trophy Points:
    38
    ok..was you managed to fix this??
     
  8. crazyaboutlinux

    crazyaboutlinux Well-Known Member

    Joined:
    Nov 3, 2007
    Messages:
    938
    Likes Received:
    0
    Trophy Points:
    16
Loading...

Share This Page