The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Dependencies

Discussion in 'General Discussion' started by Belaird, Jul 23, 2006.

  1. Belaird

    Belaird Well-Known Member

    Joined:
    Jun 24, 2004
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    6
    My nightly /scripts/upcp produces this error as part of its report:

    Testing package set / solving RPM inter-dependencies...
    There was a package dependency problem. The message was:

    Unresolvable chain of dependencies:
    perl-DBD-MySQL 2.1021-4.EL3 requires libmysqlclient.so.10


    Do i need to do a /scripts/upcp -force to resolve this or can it be done a different way?

    Thanks in advance
     
  2. minotauro

    minotauro Well-Known Member

    Joined:
    Jan 19, 2004
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    Hello,

    The same problem here... :rolleyes:

    Regards,
    Minotauro.
     
  3. dropby23

    dropby23 Well-Known Member

    Joined:
    Jan 16, 2005
    Messages:
    155
    Likes Received:
    0
    Trophy Points:
    16
    #3 dropby23, Jul 24, 2006
    Last edited: Jul 24, 2006
  4. minotauro

    minotauro Well-Known Member

    Joined:
    Jan 19, 2004
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
  5. fishfreek

    fishfreek Well-Known Member

    Joined:
    Jan 2, 2004
    Messages:
    238
    Likes Received:
    0
    Trophy Points:
    16
    Im getting this message aswell. I installed RPM MySQL-shared-compat-4.1.21-1.rhel3.i386.rpm as I am running 4.1.21 and using RHEL3. I still get the message:
    Unresolvable chain of dependencies:
    perl-DBD-MySQL 2.1021-4.EL3 requires libmysqlclient.so.10

    WHen I do a up2date -u

    I try a up2date --solvedep=perl-DBD-MySQL and get the same message.
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    That's because the perl module from RHE is older than the one from cpan which is installed on the server. I'd suggest you remove the RHE one from the rpm database to avoid the dependency conflict:

    rpm -e --justdb perl-DBD-MySQL
     
  7. fishfreek

    fishfreek Well-Known Member

    Joined:
    Jan 2, 2004
    Messages:
    238
    Likes Received:
    0
    Trophy Points:
    16
    Thanks. That took care of it. I have another server with the same issue I will see if this works aswell later.
     
  8. Parcye

    Parcye Well-Known Member

    Joined:
    May 19, 2004
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Eindhoven
    @chirpy; I would like to thank you, it also solved the problem for me. Karma for you!
     
Loading...

Share This Page