Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Dependency issues installing LDAP server

Discussion in 'Workarounds and Optimization' started by Dritan, Nov 21, 2016.

Tags:
  1. Dritan

    Dritan Registered

    Joined:
    Nov 21, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Albania
    cPanel Access Level:
    Root Administrator
    I am having dependency issues installing LDAP server.
    Ports 389, 636, 9830 have been configured for iptables.
    epel repo has been installed.
    /etc/sysctl.conf, /etc/security/limits.conf, /etc/profile, etc/pam.d/login have been added to accordingly.
    When running "yum install 389-ds openladp-clients -y" the following dependency issues come up upon attempting installation.

    Appreciate any help!
    Code:
    
    root@server [/]# yum install 389-ds openladp-clients -y
    Loaded plugins: fastestmirror, security
    Setting up Install Process
    Loading mirror speeds from cached hostfile
    * epel: mirror.sfo12.us.leaseweb.net
    No package openladp-clients available.
    Resolving Dependencies
    --> Running transaction check
    ---> Package 389-ds.noarch 0:1.2.2-1.el6 will be installed
    --> Processing Dependency: 389-dsgw for package: 389-ds-1.2.2-1.el6.noarch
    --> Processing Dependency: 389-ds-console-doc for package: 389-ds-1.2.2-1.el6.noarch
    --> Processing Dependency: 389-ds-console for package: 389-ds-1.2.2-1.el6.noarch
    --> Processing Dependency: 389-ds-base for package: 389-ds-1.2.2-1.el6.noarch
    --> Processing Dependency: 389-console for package: 389-ds-1.2.2-1.el6.noarch
    --> Processing Dependency: 389-admin-console-doc for package: 389-ds-1.2.2-1.el6.noarch
    --> Processing Dependency: 389-admin-console for package: 389-ds-1.2.2-1.el6.noarch
    --> Processing Dependency: 389-admin for package: 389-ds-1.2.2-1.el6.noarch
    --> Running transaction check
    ---> Package 389-admin.x86_64 0:1.1.35-1.el6 will be installed
    --> Processing Dependency: policycoreutils-python for package: 389-admin-1.1.35-1.el6.x86_64
    --> Processing Dependency: perl-Mozilla-LDAP for package: 389-admin-1.1.35-1.el6.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::Utils) for package: 389-admin-1.1.35-1.el6.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::LDIF) for package: 389-admin-1.1.35-1.el6.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::Conn) for package: 389-admin-1.1.35-1.el6.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::API) for package: 389-admin-1.1.35-1.el6.x86_64
    --> Processing Dependency: mod_nss for package: 389-admin-1.1.35-1.el6.x86_64
    --> Processing Dependency: libicuuc.so.42()(64bit) for package: 389-admin-1.1.35-1.el6.x86_64
    --> Processing Dependency: libicui18n.so.42()(64bit) for package: 389-admin-1.1.35-1.el6.x86_64
    --> Processing Dependency: libicudata.so.42()(64bit) for package: 389-admin-1.1.35-1.el6.x86_64
    --> Processing Dependency: libadmsslutil.so.0()(64bit) for package: 389-admin-1.1.35-1.el6.x86_64
    --> Processing Dependency: libadminutil.so.0()(64bit) for package: 389-admin-1.1.35-1.el6.x86_64
    ---> Package 389-admin-console.noarch 0:1.1.8-1.el6 will be installed
    ---> Package 389-admin-console-doc.noarch 0:1.1.8-1.el6 will be installed
    ---> Package 389-console.noarch 0:1.1.7-1.el6 will be installed
    ---> Package 389-ds-base.x86_64 0:1.2.11.15-75.el6_8 will be installed
    --> Processing Dependency: 389-ds-base-libs = 1.2.11.15-75.el6_8 for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl-Socket6 for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl-NetAddr-IP for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl-Mozilla-LDAP for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl(NetAddr::IP::Util) for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::Utils) for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::LDIF) for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::Conn) for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::API) for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: cyrus-sasl-md5 for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: cyrus-sasl-gssapi for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: libsvrcore.so.0()(64bit) for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: libslapd.so.0()(64bit) for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: libnetsnmpmibs.so.20()(64bit) for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: libnetsnmphelpers.so.20()(64bit) for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: libnetsnmpagent.so.20()(64bit) for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: libnetsnmp.so.20()(64bit) for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    ---> Package 389-ds-console.noarch 0:1.2.6-1.el6 will be installed
    ---> Package 389-ds-console-doc.noarch 0:1.2.6-1.el6 will be installed
    ---> Package 389-dsgw.x86_64 0:1.1.11-1.el6 will be installed
    --> Processing Dependency: perl-Mozilla-LDAP for package: 389-dsgw-1.1.11-1.el6.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::Utils) for package: 389-dsgw-1.1.11-1.el6.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::Conn) for package: 389-dsgw-1.1.11-1.el6.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::API) for package: 389-dsgw-1.1.11-1.el6.x86_64
    --> Running transaction check
    ---> Package 389-admin.x86_64 0:1.1.35-1.el6 will be installed
    --> Processing Dependency: perl-Mozilla-LDAP for package: 389-admin-1.1.35-1.el6.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::Utils) for package: 389-admin-1.1.35-1.el6.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::LDIF) for package: 389-admin-1.1.35-1.el6.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::Conn) for package: 389-admin-1.1.35-1.el6.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::API) for package: 389-admin-1.1.35-1.el6.x86_64
    ---> Package 389-adminutil.x86_64 0:1.1.19-1.el6 will be installed
    ---> Package 389-ds-base.x86_64 0:1.2.11.15-75.el6_8 will be installed
    --> Processing Dependency: perl-Socket6 for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl-NetAddr-IP for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl-Mozilla-LDAP for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl(NetAddr::IP::Util) for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::Utils) for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::LDIF) for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::Conn) for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::API) for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    ---> Package 389-ds-base-libs.x86_64 0:1.2.11.15-75.el6_8 will be installed
    ---> Package 389-dsgw.x86_64 0:1.1.11-1.el6 will be installed
    --> Processing Dependency: perl-Mozilla-LDAP for package: 389-dsgw-1.1.11-1.el6.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::Utils) for package: 389-dsgw-1.1.11-1.el6.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::Conn) for package: 389-dsgw-1.1.11-1.el6.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::API) for package: 389-dsgw-1.1.11-1.el6.x86_64
    ---> Package cyrus-sasl-gssapi.x86_64 0:2.1.23-15.el6_6.2 will be installed
    ---> Package cyrus-sasl-md5.x86_64 0:2.1.23-15.el6_6.2 will be installed
    ---> Package libicu.x86_64 0:4.2.1-14.el6 will be installed
    ---> Package mod_nss.x86_64 0:1.0.10-6.el6 will be installed
    --> Processing Dependency: httpd-mmn = 20051115 for package: mod_nss-1.0.10-6.el6.x86_64
    --> Processing Dependency: httpd for package: mod_nss-1.0.10-6.el6.x86_64
    ---> Package net-snmp-libs.x86_64 1:5.5-57.el6_8.1 will be installed
    --> Processing Dependency: libsensors.so.4()(64bit) for package: 1:net-snmp-libs-5.5-57.el6_8.1.x86_64
    ---> Package policycoreutils-python.x86_64 0:2.0.83-29.el6 will be installed
    --> Processing Dependency: libsemanage-python >= 2.0.43-4 for package: policycoreutils-python-2.0.83-29.el6.x86_64
    --> Processing Dependency: audit-libs-python >= 1.4.2-1 for package: policycoreutils-python-2.0.83-29.el6.x86_64
    --> Processing Dependency: setools-libs-python for package: policycoreutils-python-2.0.83-29.el6.x86_64
    --> Processing Dependency: libselinux-python for package: policycoreutils-python-2.0.83-29.el6.x86_64
    --> Processing Dependency: libcgroup for package: policycoreutils-python-2.0.83-29.el6.x86_64
    ---> Package svrcore.x86_64 0:4.0.4-5.1.el6 will be installed
    --> Running transaction check
    ---> Package 389-admin.x86_64 0:1.1.35-1.el6 will be installed
    --> Processing Dependency: perl-Mozilla-LDAP for package: 389-admin-1.1.35-1.el6.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::Utils) for package: 389-admin-1.1.35-1.el6.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::LDIF) for package: 389-admin-1.1.35-1.el6.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::Conn) for package: 389-admin-1.1.35-1.el6.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::API) for package: 389-admin-1.1.35-1.el6.x86_64
    ---> Package 389-ds-base.x86_64 0:1.2.11.15-75.el6_8 will be installed
    --> Processing Dependency: perl-Socket6 for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl-NetAddr-IP for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl-Mozilla-LDAP for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl(NetAddr::IP::Util) for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::Utils) for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::LDIF) for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::Conn) for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::API) for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    ---> Package 389-dsgw.x86_64 0:1.1.11-1.el6 will be installed
    --> Processing Dependency: perl-Mozilla-LDAP for package: 389-dsgw-1.1.11-1.el6.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::Utils) for package: 389-dsgw-1.1.11-1.el6.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::Conn) for package: 389-dsgw-1.1.11-1.el6.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::API) for package: 389-dsgw-1.1.11-1.el6.x86_64
    ---> Package audit-libs-python.x86_64 0:2.4.5-3.el6 will be installed
    ---> Package libcgroup.x86_64 0:0.40.rc1-18.el6_8 will be installed
    ---> Package libselinux-python.x86_64 0:2.0.94-7.el6 will be installed
    ---> Package libsemanage-python.x86_64 0:2.0.43-5.1.el6 will be installed
    ---> Package lm_sensors-libs.x86_64 0:3.1.1-17.el6 will be installed
    ---> Package mod_nss.x86_64 0:1.0.10-6.el6 will be installed
    --> Processing Dependency: httpd-mmn = 20051115 for package: mod_nss-1.0.10-6.el6.x86_64
    --> Processing Dependency: httpd for package: mod_nss-1.0.10-6.el6.x86_64
    ---> Package setools-libs-python.x86_64 0:3.3.7-4.el6 will be installed
    --> Processing Dependency: setools-libs = 3.3.7-4.el6 for package: setools-libs-python-3.3.7-4.el6.x86_64
    --> Processing Dependency: libsefs.so.4(VERS_4.0)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
    --> Processing Dependency: libseaudit.so.4(VERS_4.2)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
    --> Processing Dependency: libseaudit.so.4(VERS_4.1)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
    --> Processing Dependency: libqpol.so.1(VERS_1.4)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
    --> Processing Dependency: libqpol.so.1(VERS_1.3)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
    --> Processing Dependency: libqpol.so.1(VERS_1.2)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
    --> Processing Dependency: libpoldiff.so.1(VERS_1.3)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
    --> Processing Dependency: libpoldiff.so.1(VERS_1.2)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
    --> Processing Dependency: libapol.so.4(VERS_4.1)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
    --> Processing Dependency: libapol.so.4(VERS_4.0)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
    --> Processing Dependency: libsefs.so.4()(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
    --> Processing Dependency: libseaudit.so.4()(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
    --> Processing Dependency: libqpol.so.1()(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
    --> Processing Dependency: libpoldiff.so.1()(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
    --> Processing Dependency: libapol.so.4()(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
    --> Running transaction check
    ---> Package 389-admin.x86_64 0:1.1.35-1.el6 will be installed
    --> Processing Dependency: perl-Mozilla-LDAP for package: 389-admin-1.1.35-1.el6.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::Utils) for package: 389-admin-1.1.35-1.el6.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::LDIF) for package: 389-admin-1.1.35-1.el6.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::Conn) for package: 389-admin-1.1.35-1.el6.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::API) for package: 389-admin-1.1.35-1.el6.x86_64
    ---> Package 389-ds-base.x86_64 0:1.2.11.15-75.el6_8 will be installed
    --> Processing Dependency: perl-Socket6 for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl-NetAddr-IP for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl-Mozilla-LDAP for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl(NetAddr::IP::Util) for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::Utils) for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::LDIF) for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::Conn) for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::API) for package: 389-ds-base-1.2.11.15-75.el6_8.x86_64
    ---> Package 389-dsgw.x86_64 0:1.1.11-1.el6 will be installed
    --> Processing Dependency: perl-Mozilla-LDAP for package: 389-dsgw-1.1.11-1.el6.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::Utils) for package: 389-dsgw-1.1.11-1.el6.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::Conn) for package: 389-dsgw-1.1.11-1.el6.x86_64
    --> Processing Dependency: perl(Mozilla::LDAP::API) for package: 389-dsgw-1.1.11-1.el6.x86_64
    ---> Package mod_nss.x86_64 0:1.0.10-6.el6 will be installed
    --> Processing Dependency: httpd-mmn = 20051115 for package: mod_nss-1.0.10-6.el6.x86_64
    --> Processing Dependency: httpd for package: mod_nss-1.0.10-6.el6.x86_64
    ---> Package setools-libs.x86_64 0:3.3.7-4.el6 will be installed
    --> Finished Dependency Resolution
    Error: Package: mod_nss-1.0.10-6.el6.x86_64 (base)
    Requires: httpd-mmn = 20051115
    Error: Package: 389-dsgw-1.1.11-1.el6.x86_64 (epel)
    Requires: perl(Mozilla::LDAP::Utils)
    Error: Package: 389-ds-base-1.2.11.15-75.el6_8.x86_64 (updates)
    Requires: perl(NetAddr::IP::Util)
    Error: Package: 389-admin-1.1.35-1.el6.x86_64 (epel)
    Requires: perl(Mozilla::LDAP::LDIF)
    Error: Package: 389-ds-base-1.2.11.15-75.el6_8.x86_64 (updates)
    Requires: perl(Mozilla::LDAP::Conn)
    Error: Package: 389-dsgw-1.1.11-1.el6.x86_64 (epel)
    Requires: perl-Mozilla-LDAP
    Error: Package: 389-ds-base-1.2.11.15-75.el6_8.x86_64 (updates)
    Requires: perl-NetAddr-IP
    Error: Package: mod_nss-1.0.10-6.el6.x86_64 (base)
    Requires: httpd
    Error: Package: 389-admin-1.1.35-1.el6.x86_64 (epel)
    Requires: perl(Mozilla::LDAP::API)
    Error: Package: 389-admin-1.1.35-1.el6.x86_64 (epel)
    Requires: perl(Mozilla::LDAP::Conn)
    Error: Package: 389-admin-1.1.35-1.el6.x86_64 (epel)
    Requires: perl-Mozilla-LDAP
    Error: Package: 389-ds-base-1.2.11.15-75.el6_8.x86_64 (updates)
    Requires: perl(Mozilla::LDAP::LDIF)
    Error: Package: 389-dsgw-1.1.11-1.el6.x86_64 (epel)
    Requires: perl(Mozilla::LDAP::API)
    Error: Package: 389-ds-base-1.2.11.15-75.el6_8.x86_64 (updates)
    Requires: perl(Mozilla::LDAP::Utils)
    Error: Package: 389-ds-base-1.2.11.15-75.el6_8.x86_64 (updates)
    Requires: perl-Mozilla-LDAP
    Error: Package: 389-ds-base-1.2.11.15-75.el6_8.x86_64 (updates)
    Requires: perl(Mozilla::LDAP::API)
    Error: Package: 389-admin-1.1.35-1.el6.x86_64 (epel)
    Requires: perl(Mozilla::LDAP::Utils)
    Error: Package: 389-ds-base-1.2.11.15-75.el6_8.x86_64 (updates)
    Requires: perl-Socket6
    Error: Package: 389-dsgw-1.1.11-1.el6.x86_64 (epel)
    Requires: perl(Mozilla::LDAP::Conn)
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
    root@server [/]# 
    
     
    #1 Dritan, Nov 21, 2016
    Last edited by a moderator: Nov 21, 2016
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Installing the OpenLDAP package on your system is unsupported, and likely to require manual intervention beyond the standard installation steps that you'd take on a vanilla CentOS installation.

    Generally, we see requests from users installing the mod_ldap Apache module as opposed to the LDAP server itself:

    Apache Module: LDAP - EasyApache - cPanel Documentation

    Thank you.
     
    Dritan likes this.
Loading...

Share This Page