Deprecated cPanel API 1 usage detected

psytanium

Well-Known Member
Jun 6, 2014
291
15
68
Lebanon
cPanel Access Level
Root Administrator
Hello,

Today I received this message by email :

You are receiving this notification because one of your accounts uses a custom cPanel integration or plugin that relies on the cPanel API 1 system. We deprecated cPanel API 1 in 2012 and plan to begin removing it from the product in cPanel & WHM version 88. This server is currently on cPanel & WHM version “86.0.4”.

It happened after I gave root access to a system administrator. I'm afraid he implemented a malware of something.

Anyway, how should I take action regarding this email ?

Thank you :)
 

quietFinn

Well-Known Member
Feb 4, 2006
1,329
141
193
Finland
cPanel Access Level
Root Administrator
As the email says "your accounts uses a custom cPanel integration or plugin that relies on the cPanel API 1 system", and they "plan to begin removing it (cPanel API 1) from the product in cPanel & WHM version 88".
Probably your server was updated to v.86 and it triggered that email.
 
  • Like
Reactions: psytanium

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,271
313
Houston
This sounds like the official notification that goes out when you're using a plugin/integration that utilizes cpapi1, we have recently been taking great strides to move everything to uapi in the anticipation for the removal of cpapi1.

You should identify the specific plugin/integration that relies on this and move to an updated version that does not utilize cpapi1 or find an alternate solution for it.
 
Last edited:

psytanium

Well-Known Member
Jun 6, 2014
291
15
68
Lebanon
cPanel Access Level
Root Administrator
This sounds like the official notification that goes out when you're using a plugin/integration that utilizes cpapi1, we have recently been taking great strides to move everything to uapi in the anticipation for the removal of cpapi1 and cpapi2.

You should identify the specific plugin/integration that relies on this and move to an updated version that does not utilize cpapi1 or find an alternate solution for it.
How can i find the plugin that use cp api1 ?
 

cPanelTJ

Product Owner
Staff member
Jan 29, 2019
95
45
93
Houston, TX
cPanel Access Level
Root Administrator
Twitter
  • Like
Reactions: cPanelLauren

Damian

Well-Known Member
Oct 1, 2001
108
7
318
In the email I’m seeing

Code:
usr/local/cpanel/base/frontend/paper_lantern/index.html                         52
how do identify the plugin?