The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

/dev/root missing

Discussion in 'General Discussion' started by kaplanDani, Apr 21, 2016.

  1. kaplanDani

    kaplanDani Registered

    Joined:
    Apr 19, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Israel
    cPanel Access Level:
    Root Administrator
    I've seen many pages on the web about this.
    I'm runnign cpanel on centos 7
    they removed the /dev/root from ver. 6 already,
    Yet I keep getting mails from cpanel -
    repquota: Cannot stat() mounted device /dev/root: No such file or directory

    How can I fix that ?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you provide some more details about your server environment? EX:

    Code:
    uname -r
    Also, are you using a provider such as Linode or OVH?

    Thank you.
     
  3. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,577
    Likes Received:
    40
    Trophy Points:
    48
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    check if you got a sybolic link and that it is correct your /etc/fstab should be correct
    ln -s /dev/yourrootdevice /dev/root


    as Michael said if you using some of OVH & linode images you may need to add
    KERNEL=="yourrootdevice", SUBSYSTEM=="block", SYMLINK+="root"

    to /etc/udev/rules.d/99-root-link.rules so the symbolic link survives a reboot
     
Loading...

Share This Page