The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Diagnostics Email Error with PHP 5.6

Discussion in 'E-mail Discussions' started by Nirjonadda, Sep 16, 2015.

  1. Nirjonadda

    Nirjonadda Well-Known Member

    Joined:
    May 8, 2013
    Messages:
    151
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    Website Owner
    I am getting error to email sending with PHP 5.6, No issue with PHP 5.5. Please let me fix on this issue.
    ------------------------------------------
    The mailing function returned an error while trying to send the mail.
    The following errors were outputted by PHP when attempting to send mail:

    PHP Warning: fsockopen(): SSL operation failed with code 1. OpenSSL Error messages: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed in ..../includes/class_mail.php on line 757

    PHP Warning: fsockopen(): Failed to enable crypto in ..../includes/class_mail.php on line 757

    PHP Warning: fsockopen(): unable to connect to ssl://na.nirmoladda.com:465 (Unknown error) in ..../includes/class_mail.php on line 757

    PHP User Warning: Unable to connect to SMTP server in ..../includes/class_mail.php on line 716

    vbulletin.com/forum/filedata/fetch?id=4325284
     
    #1 Nirjonadda, Sep 16, 2015
    Last edited by a moderator: Sep 16, 2015
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Have you seen this thread?
    vbulletin.com/forum/forum/vbulletin-4/vbulletin-4-questions-problems-and-troubleshooting/4325283-diagnostics-email-error-with-php-5-6-11

    Of course you have, its your thread. :eek:
     
  3. Nirjonadda

    Nirjonadda Well-Known Member

    Joined:
    May 8, 2013
    Messages:
    151
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    Website Owner
    Yes, I am with this thread but this thread does not help. Please, do you have any other Suggestions?
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  5. Nirjonadda

    Nirjonadda Well-Known Member

    Joined:
    May 8, 2013
    Messages:
    151
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    Website Owner
    Yes, but Still have a same issue.
     
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I think I might try reinstalling the certificate and take note of the suggestions mentioned in that thread.
     
  7. Nirjonadda

    Nirjonadda Well-Known Member

    Joined:
    May 8, 2013
    Messages:
    151
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    Website Owner
    What certificate need to reinstalling? I am not using https. I Connected to the my hosting providers and get response.

     
    #7 Nirjonadda, Sep 18, 2015
    Last edited by a moderator: Sep 18, 2015
  8. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Sorry. At the bottom of the "Email Options" page in your vBadmin, find this option:
    SMTP Secure Connection

    Set this to TLS, or, None.

    Back on the Diagnostics page again, try the email diagnostic again to see if it goes through now. The response there should be:

     
  9. Nirjonadda

    Nirjonadda Well-Known Member

    Joined:
    May 8, 2013
    Messages:
    151
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    Website Owner
    Does not get fixed, Now getting this error with TLS, or, None

    Code:
    Results
    The mailing function returned an error while trying to send the mail.
    The following errors were outputted by PHP when attempting to send mail:
    
    
    PHP User Warning: 0 Unexpected response when connecting to SMTP server in ..../includes/class_mail.php on line 716
     
  10. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Are you sure you've got your Email Options set correctly?
     
  11. Nirjonadda

    Nirjonadda Well-Known Member

    Joined:
    May 8, 2013
    Messages:
    151
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    Website Owner
    PHP 5.5 are still working With this Email Options setting.
     
  12. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I don't have a server running 5.6 with an install of vBulletin on it to try and duplicate this. You might want to open a ticket to vBulletin support about this so they can take a closer look. Or contact your Hosting Provider.
     
  13. Nirjonadda

    Nirjonadda Well-Known Member

    Joined:
    May 8, 2013
    Messages:
    151
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    Website Owner
    I am now get back to PHP 5.5, Can you do check it, If i send you login Information? I Connected to the my hosting providers and get response from Now but I did not understand in about what locations set for openssl.cafile and openssl.capath? Can you say me that, what response i give my hosting provider?

     
  14. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
  15. Nirjonadda

    Nirjonadda Well-Known Member

    Joined:
    May 8, 2013
    Messages:
    151
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    Website Owner
    I am now set Email Options setting to None and now vBulletin Email Test are working, but why i am cannot get working "Email Options" Set this to SSL/TLS with PHP 5.6?
     
  16. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    The devs over at vB would have to answer that for you I suppose. Aside from the comments already posted over there in your thread.

    This isn't a cPanel issue though. ;)

    Glad to hear you got it going.
     
Loading...

Share This Page