The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Did the new cpanel upgrade affect the Pipe in any way.

Discussion in 'General Discussion' started by tommytx, Jun 4, 2012.

  1. tommytx

    tommytx Member

    Mar 30, 2006
    Likes Received:
    Trophy Points:
    I have been running a simple pipe in a subdirectory for the past several years and all of a sudden it stopped the other day when I accepted the cpanel upgrade at my VPS.

    Below is what my basic code looks like and I set up a forwarder on cpanel like so:
    ************************************************************ -> |/home/user/public_html/mail/mail.php

    #!/usr/bin/php -q
    /* Read the message from STDIN */
    $fd = fopen("php://stdin", "r"); 
    $email = ""; // This will be the variable holding the data.
    while (!feof($fd)) {
    $email .= fread($fd, 1024);
    /* Saves the data into a file */
    // $fdw = fopen("/home/user/public_html/mail/mail.txt", "w+");
    $fdw = fopen("mail.txt", "w+");
    fwrite($fdw, "This is a test.\n");
    fwrite($fdw, $email);
    /* Script End */
    echo "<br>That is all folks<br>";
    My host has worked diligently with me on this problem, and we thought we had it fixed... but no..
    So thought I might post here in the hopes that someone else is having similar problems.
    We did solve some bounce problems coming from the pipe, but now I find out the the $email is not populating with the data from the email. $email is always empty.
    It has worked well for years is the reason i suspect the cpanel upgrade.
    Any thoughts or ideas would be greatly appreciated.


Share This Page