Difficulty Sending Mail from Server

Uneschewed

Member
May 13, 2019
16
0
1
Missouri
cPanel Access Level
Root Administrator
Hello,

I have a new server set up, where I am able to receive mail, but not send any out. I have a private IP address and a public IP address as part of my set up. I can see in WHM the Resolver Configuration has not been ran. I get a message when sending mail that says :

all hosts for 'gmail.com' have been failing for a long time (and retry time not reached)

Do I need to run the Resolver Configuration to send mail, I have an MX record set at remote dns showing Host: example.com and Points To: mail.example.com.

Do I need to set the points to to something else, I have an A record set that shows Host: mail.example.com is pointed to my public IP address for my server. If I need to set up Resolver Configuration do I need to set it to my public IP address or my private IP address?

Secondly, do I need to change my MX record, or is this properly set?
 

Uneschewed

Member
May 13, 2019
16
0
1
Missouri
cPanel Access Level
Root Administrator
Hello,

I found that I had not set the DKIM and SPF TXT records at the DNS server. I set them and did a reboot of the server, yet the Email Deliverability still shows I do not have the DKIM and SPF records set. I have the mail.example.com correctly pointed to my IP address, what to try next to address the concerns?
 

cPanelLauren

Forums Analyst II
Staff member
Nov 14, 2017
6,762
535
263
Houston
cPanel Access Level
DataCenter Provider