The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Directory Alias/Virtual Directory in Shared Hosting

Discussion in 'General Discussion' started by Anthony Brian Mallgren, Dec 12, 2015.

  1. Anthony Brian Mallgren

    Anthony Brian Mallgren Active Member

    Joined:
    Dec 12, 2015
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    United States
    cPanel Access Level:
    Website Owner
    Twitter:
    I have an agreement for a shared hosting package with GoDaddy, using Linux and CPanel. When I attempt to create a directory alias (also known as a virtual directory), I see no reasonable means of doing so.

    There is this thread: Directory Alias in WHM or Cpanel

    Although, the links seem to redirect to a default page. I have attempted to lookup enabling custom Apache modules. I have also attempted to utilize the ln command to create symbolic links of directories, but it seems that an Apache configuration to enable following linked directories is required to do so.

    I am not able to find the httpd.conf file for the server I am on.

    Any ideas?
     
  2. Anthony Brian Mallgren

    Anthony Brian Mallgren Active Member

    Joined:
    Dec 12, 2015
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    United States
    cPanel Access Level:
    Website Owner
    Twitter:
    Disregard. I figured it out.
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  4. Anthony Brian Mallgren

    Anthony Brian Mallgren Active Member

    Joined:
    Dec 12, 2015
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    United States
    cPanel Access Level:
    Website Owner
    Twitter:
    The ln command seemed to work once I used fully qualified paths.
     
Loading...

Share This Page