The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Directory permission on create via ssh

Discussion in 'General Discussion' started by maxgdias, Mar 28, 2012.

  1. maxgdias

    maxgdias Registered

    Joined:
    Feb 25, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello I am new in cPanel.
    I have a dedicated server with WHM / cPanel. I have the following problem:
    1 - When I upload the zip file via FTP, All right. the permission was 755 (directory) and 644 (files)
    2 - After extracting the zip file, all directories was with permission 700. Why ??
    How can I adjust the WHM to become the default permissions to 755?
    Where is this setting that always leaves in 700?
    Can you help me?
    Thank you,
    Max
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    When extracting a zip archive, it should extract the files/directories with the same permissions that were assigned at the time the files were archived. If this is not happening, please open a support ticket so we can check further:

    Submit A Ticket

    Thank you.
     
  3. linux7802

    linux7802 Well-Known Member

    Joined:
    Dec 14, 2007
    Messages:
    232
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Hello,

    Yes, cPanelMichael is correct. If you would like to test it then extract the file on the local machine and check the permission and if you are facing the file/directory permission while creating the new file/directory on the server then make sure that your server having umask set to 0022.

    You can verify the umask by using the following command from the shell.

    [root@~]# umask
    0022
     
Loading...

Share This Page