The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Disable Auto White List (AWL) in SA

Discussion in 'E-mail Discussions' started by sehh, Jul 17, 2008.

  1. sehh

    sehh Well-Known Member

    Joined:
    Feb 11, 2006
    Messages:
    579
    Likes Received:
    5
    Trophy Points:
    18
    Location:
    Europe
    How can i disable the Auto White List (AWL) feature in Spamassassin?
     
  2. bazzi

    bazzi Well-Known Member

    Joined:
    May 23, 2004
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    16
    commend out in /etc/mail/spamassassin/v310.pre:
    loadplugin Mail::SpamAssassin::Plugin::AWL

    so change it to:
    #loadplugin Mail::SpamAssassin::Plugin::AWL

    But why would you do that?
     
  3. sehh

    sehh Well-Known Member

    Joined:
    Feb 11, 2006
    Messages:
    579
    Likes Received:
    5
    Trophy Points:
    18
    Location:
    Europe
    because we get weird results, like the following:

    14 AWL AWL: From: address is in the auto white-list

    14 points (5 is spam!) for white listing? thats more like auto black listing...
     
  4. bazzi

    bazzi Well-Known Member

    Joined:
    May 23, 2004
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    16
    did you remove the autowithlist files?
    Maybe is the database corrupt.
    you find them:

    /home/*user*/.spamassassin/auto-whitelist

    Then you start with a clean database for that user...
     
  5. bazzi

    bazzi Well-Known Member

    Joined:
    May 23, 2004
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    16
    No i try to say that a solution can be to remove that files. spamassassin will automaticly make new clean files. So you start with a fresh database if you remove them. ;)

    You easally can remove all files with:
    rm -f /home/*/.spamassassin/auto-whitelist

    EDIT: Ther is something wrong in the forum... I repleyed on:
    But my post is newer :s
     
    #5 bazzi, Jul 18, 2008
    Last edited: Jul 18, 2008
  6. sehh

    sehh Well-Known Member

    Joined:
    Feb 11, 2006
    Messages:
    579
    Likes Received:
    5
    Trophy Points:
    18
    Location:
    Europe
    no i haven't touched any files, and my users don't have access to the server in order to mess with the home directory files.

    i've disabled AWL and i'll see how that goes, maybe in the future i'll re-enable it.
     
Loading...

Share This Page