Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Disable AutoSSL user notifications is not working

Discussion in 'Security' started by falcon99, Mar 4, 2019.

  1. falcon99

    falcon99 Registered

    Joined:
    Jun 11, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    51
    I am running WHM v78.0.13 with Options set to Disable AutoSSL user notifications.

    This used to work but in recent WHM versions has stopped working and my end users are
    receiving notifications by email with my clients receiving the following email:

    The SSL certificate expires on Mar 23, 2019 at 12:00:00 AM UTC. At the time of this notice, the certificate will expire in “19 days, 12 hours, 34 minutes, and 39 seconds”.
    The SSL certificate for “xxxxxxxxxxxxx.com” has not been renewed. You must take action to secure this site.

    Will Cpanel fix this so that when "Disable AutoSSL user notifications"
    is selected it will actually stop all emails being sent to end users?
     
    #1 falcon99, Mar 4, 2019
    Last edited by a moderator: Mar 4, 2019
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,534
    Likes Received:
    2,181
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @falcon99,

    Can you verify if Send notifications when certificates approach expiry is enabled under the Notifications tab in WHM >> Tweak Settings? If it's enabled, can you also check if the SSL certificate installed on the account referenced in the notification email was issued by AutoSSL?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. falcon99

    falcon99 Registered

    Joined:
    Jun 11, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    51
    Hello,

    Thats yes and yes. The problem is its sending out these emails 21 or more days before expiry telling people they need to take action, when the autossl renews just 7 days before expiry. I have disabled the notification under Tweak Settings now.
     
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,534
    Likes Received:
    2,181
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @falcon99,

    If the certificate was issued by AutoSSL (as opposed to a non-AutoSSL certificate) and Disable AutoSSL user notifications is enabled in WHM >> Manage AutoSSL, then the user should not receive the expiry warning. Can you open a support ticket so we can take a closer look at your system if this isn't working as intended? You can post the ticket number here and we'll update this thread with the outcome.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice