Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Disable daily /scripts/upcp emails

Discussion in 'E-mail Discussion' started by marcochiesi, Mar 3, 2011.

  1. marcochiesi

    marcochiesi Member

    Joined:
    Mar 1, 2011
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    51
    Location:
    Italy
    cPanel Access Level:
    Root Administrator
    Twitter:
    I forwarded the root mailbox to my address and I receive the notification from /scripts/upcp every night.
    Is there a way to disable these emails, or at least be notified only if something goes wrong during the update?
    I would like to keep the root forward, but all these messages are a bit annoying, and, as it is now, it's hard to notice possible problems in the log.
     
  2. vanessa

    vanessa Well-Known Member
    PartnerNOC

    Joined:
    Sep 26, 2006
    Messages:
    834
    Likes Received:
    29
    Trophy Points:
    178
    Location:
    Virginia Beach, VA
    cPanel Access Level:
    DataCenter Provider
    I would add /dev/null 2>&1 to the /scripts/upcp cron job.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. maximux1

    maximux1 Registered

    Joined:
    Mar 21, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    151
    I'm having this problem as well.

    Each day I get an email after upcp runs. I have a .forward setup for roots email. There is no email address setup in the root cron file. There's also no problem with the upcp run;

    ===========================================
    <snip>
    [20120422.224021] Maintenance completed successfully
    [20120422.224021]
    [20120422.224021] cPanel update completed
    [20120422.224021] A log of this update is available at /var/cpanel/updatelogs/update.1335159601.log
    [20120422.224021] Removing upcp pidfile
    [20120422.224021]
    [20120422.224021] Completed all updates
    => Log closed Sun Apr 22 22:40:21 2012
    [end]
    ===========================================

    I've added /dev/null 2>&1 however the emails still come.

    The subject did change - now it reads;

    Subject> Cron <root@74> /usr/local/cpanel/scripts/upcp --cron /dev/null 2>&1

    All I am looking to do is disable these emails. Any ideas?

    Thank you
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice