Disable emails from going to Junk folder on webmail

altinix

Member
Aug 29, 2016
7
0
1
Tirana, Albania
cPanel Access Level
DataCenter Provider
Hello,

I'm having an issue regarding some legitimate emails going to the Junk folder on webmail, and as a result, I can't pull these emails using POP3, (because this checks only Inbox folder). These emails are legitimate ones, like from CPHulk, or of the same domain as my email address.
This issue started a few days ago, I think when cPanel updated to version
WHM 62.0 (build 10)
As of now, it is only me who has emails delivered to Junk folder. Other accounts don't have this issue...as of now. (the same email is being delivered to them in Inbox).
I have deleted and setup the account from the start on cPanel.
Tried to setup some spam filter to be delivered to the INbox folder.
Restarted Exim service.
Tried unsubsribing the Junk folder but emails keep getting there.
Disabled SpamAssasin on this domain, but none of them work.
Any suggestion how to resolve this?

Also, with exigrep I see this issue like being delivered like below: (haven't seen this before)
/home/cpanel_account/mail/domain/user_address/
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Hello,

Could you post the output from /var/log/exim_mainlog for one of the affected messages? EX:

Code:
exigrep MSGID /var/log/exim_mainlog
Thank you.
 

altinix

Member
Aug 29, 2016
7
0
1
Tirana, Albania
cPanel Access Level
DataCenter Provider
My address is [email protected]. These CP Hulk emails are sent to an alias [email protected] and my address and [email protected] are members of this alias.
Elis.koci has no issues.
Code:
[email protected] [~]# exigrep 1cdUXl-0008Jw-0R /var/log/exim_mainlog
2017-02-14 05:16:45 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1cdUXl-0008Jw-0R

2017-02-14 05:16:45 1cdUXl-0008Jw-0R <= [email protected] U=root P=local S=44851 T="[mail.example.al] \342\232\240 Excessive Number of Failed Login Attempts from 42.48.xx.xx (China:CN)" for [email protected]
2017-02-14 05:16:45 1cdUXl-0008Jw-0R => /home/example/mail/example.al/altini/ ([email protected], [email protected], [email protected], [email protected]) <[email protected]> R=virtual_user_filter T=address_directory
2017-02-14 05:16:46 1cdUXl-0008Jw-0R => elis.koci ([email protected], [email protected]mple.al, [email protected]) <[email protected]> R=virtual_user T=dovecot_virtual_delivery C="250 2.0.0 <[email protected]> dLW0Kq2EolgPfQAAQAeGbg Saved"
2017-02-14 05:16:46 1cdUXl-0008Jw-0R Completed
I haven't created any filters for incoming spam like the logs are stating:
Code:
/home/example/mail/example.al/altini/ ([email protected], [email protected]) <[email protected]> R=virtual_user_filter T=address_directory
 
Last edited by a moderator:

sktest123

Well-Known Member
Jan 31, 2017
99
6
8
kochin
cPanel Access Level
Root Administrator
Since the Route is indicating as ( R=virtual_user_filter) it's an email account level filter , please check the path /home/example/etc/example.al/(filtername) to identify it or via the cpanel email filters . Either way an email level filtering is triggering here.
 
Last edited by a moderator:

altinix

Member
Aug 29, 2016
7
0
1
Tirana, Albania
cPanel Access Level
DataCenter Provider
I have already deleted the account, and did setup a new one.
There are no email filters created for the account. It's just a newly account.
Also the path /home/example/etc/example.al/altini is empty.
Is there any way to look any more deep for these filters?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Hello,

Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
I'm having the identical issue on my domain. Did you find a resolution to this problem?
Hello,

This turned out to be an issue with a local email client filtering the messages, as opposed to the server or cPanel filtering the message. Try changing the password to the email account and testing with individual email clients to determine which one is filtering the message.

Thank you.