Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Disable Ftp quota check

Discussion in 'General Discussion' started by Kelvin Soares, Mar 5, 2016.

  1. Kelvin Soares

    Kelvin Soares Registered

    Dec 17, 2015
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    It's possible I can run upcp with skip ftpquotacheck '/usr/local/cpanel/scripts/ftpquotacheck'?

    I have a server that has an account with about 470G, so lately when I have run a upcp, it crashes and dies due to 'ftpquotacheck' procedure take too long.

    /etc/redhat-release:CentOS release 6.7 (Final)
    I have to update cPanel as quickly as possible, because of a exim security breach, but the procedure always hangs due to account size. The locking point is this:

    [2016-03-05 18:14:58 -0500]      [28499] PHP version file is up to date
    [2016-03-05 18:14:58 -0500]    - Processing command `/usr/local/cpanel/scripts/checkerrorlogsafe`
    [2016-03-05 18:14:58 -0500]   40% complete
    [2016-03-05 18:14:58 -0500]    - Processing command `/usr/local/cpanel/scripts/listcheck`
    [2016-03-05 18:14:58 -0500]   41% complete
    [2016-03-05 18:14:58 -0500]    - Processing command `/usr/local/cpanel/scripts/ftpquotacheck`
    [2016-03-05 18:14:58 -0500]      [28503] Ftp Quota Check v1.8
    [2016-03-05 18:15:00 -0500]      [28503] [ftpquotacheck] Setting I/O priority to reduce system load: best-effort: prio 6
    Full log - Removed -.

    Any help and tip will be welcome, thank you.

    #1 Kelvin Soares, Mar 5, 2016
    Last edited by a moderator: Mar 5, 2016
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Apr 11, 2011
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    Hello :)

    You can browse to the "System" tab in "WHM >> Tweak Settings" and change the "Interval, in days, between rebuilds of the FTP quota and disk usage data (applies to Pure-FTPd only)" value from "30" to a higher number (however long ago it's been since "/usr/local/cpanel/scripts/ftpquotacheck" last ran). Then, run "/scripts/upcp" to see if it proceeds past this point. Or, another option, is to temporarily switch to "ProFTPd" before updating cPanel via "WHM >> FTP Server Selection"

    Thank you.
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice