The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Disable httpd use of port 80 on specific IP?

Discussion in 'General Discussion' started by bozieboz, Sep 22, 2004.

  1. bozieboz

    bozieboz Registered

    Joined:
    Mar 11, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    On a certain IP on my server, I want another program (SHOUTcast) to use port 80.

    How do I go about disabling the httpd service for a certain IP/port?

    Thanks,
    -Brian
     
  2. carluk

    carluk Well-Known Member

    Joined:
    Sep 2, 2003
    Messages:
    162
    Likes Received:
    0
    Trophy Points:
    16
    Have you tried installing it on the server and seeing if it will run? Come across any errors?
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Make sure that you don't have any VirtualHosts using the IP address and that you have noe NameVirtualHost entries for it either in /etc/httpd/conf/httpd.conf
     
  4. bozieboz

    bozieboz Registered

    Joined:
    Mar 11, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    When I try to start my SHOUTcast server on that IP address, using port 80... I get an error (from SHOUTcast) that there is something already using that port.

    When I shut down httpd, I can start SHOUTcast just fine on port 80, but then httpd fails to start.

    There is nothing specifically set for that IP address (66.103.144.146) in httpd.conf. It looks as if CPanel is catching all requests to any of my ip's... whether they are assigned or not.

    Any way to disable this?

    -Brian
     
  5. Norman

    Norman Well-Known Member

    Joined:
    Sep 20, 2004
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    6
    Apache binds to port 80 by default.. then from under that the VHosts are delegated.. yo ucan always add a new port the vhosts for any domain..

    but by default I believe that apache will bind to port 80 for standard requests..

    this would be found in the httpd.conf file

     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
  7. bozieboz

    bozieboz Registered

    Joined:
    Mar 11, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    So. To have apache *not* listen to port 80 for that certain IP, I should set up a vhost for that IP and assign a port other than 80?
     
  8. Norman

    Norman Well-Known Member

    Joined:
    Sep 20, 2004
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    6
    Well the main apache standalone server will always bind to that port in httpd.conf when you start apache, regardless of what you got in your VirtualHosts.

    Like chirpy said, read the doc ont he Bind command and see if that helps any..
     
Loading...

Share This Page