Disable https redirection for website


Jan 24, 2017
cPanel Access Level
Root Administrator
A very weird problem has started on my website since yesterday. Neither I nor the hosting provider did anything to the VPS where my website is hosted. The problem is -
The website opens in the browsers without any problem, but when I try to test the page speed on google's website or test the gzip compression, it fails first time, but works fine when I click the button second time. The error thrown by google's pagespeed checker PageSpeed Insights
is - PageSpeed was unable to connect to the server. Ensure that you are using the correct protocol (http vs https), the page loads in a browser, and is accessible on the public Internet.

Also, I use rss reader which parses one of my XML pages. When I use http for the XML page, it works for 30 minutes and after that it gives error - There was a problem contacting your RSS feed server. If I change http to https for the XML page, rss reader starts working immediately, otherwise this error remains for 30 minutes and after that it resolves itself. So, it seems that yesterday cPanel updated something and because of that this problem started. I disabled SSL for the domain via WHM, but it didn't fix the problem. I don't want any page of my website to be redirected to https. Could you please let me know how to disable https redirection that happens after every 30 minutes. I modified .htaccess for this, but didn't work. Seems cPanel/WHM has done something that can't be overwritten by .htaccess.
Last edited by a moderator:


Staff member
Apr 11, 2011

Could you open a support ticket using the link in my signature so we can take a closer look at your system to see what's happening? You can post the ticket number here so we can update this thread with the outcome.

Thank you.