The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

disable localhost resolution in exim

Discussion in 'E-mail Discussions' started by Vince778, Jan 17, 2011.

  1. Vince778

    Vince778 Member

    Joined:
    Jan 1, 2010
    Messages:
    14
    Likes Received:
    1
    Trophy Points:
    3
    My email all needs to be passed off to other servers like Gmail or Yahoo mail servers where the MX record for my website are actually pointing, but Exim insists on resolving all mail generated buy my websites scripts locally since my last major upgrade of cPanel. I want Exim to ALWAYS look up the MX record at the registrar and send stuff to where it's supposed togo, no resolutions locally. I had this working before but cant find the right place in cPanel now to disable localhost resolutions.

    Help pls, :^)

    Vince
     
    #1 Vince778, Jan 17, 2011
    Last edited: Jan 17, 2011
  2. usman43

    usman43 Member

    Joined:
    May 16, 2008
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Are you using local name servers of your server or out side name servers ? In any case make sure the entry for your domains do not exist in /etc/localdomains , you can manually remove domains from there and add them in /etc/remotedomains from console or you can use 'Edit a DNS Zone' feature for every domain and chose remote mail server instead of local or automatic selection.
     
  3. Vince778

    Vince778 Member

    Joined:
    Jan 1, 2010
    Messages:
    14
    Likes Received:
    1
    Trophy Points:
    3
    I used 'DNS Functions' -> 'Edit MX Entry' to manually select the domains one by one and change them to the correct setting. All working properly again.

    Thank you,

    Vince
     
Loading...

Share This Page