The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Disable MailScanner

Discussion in 'E-mail Discussions' started by mickalo, Mar 20, 2004.

  1. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    765
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    N.W. Iowa
    I've tried to find some info, reqarding disabling MailScanner after it's been installed, if needed. As if the MailScanner is stopped, then Exim appears not to function or send/recieve any emails.

    What is the proper proceedure to disable MailScanner and still have Exim work properly w/o MailScanner even tho it's been installed ??

    TIA,
    Mickalo
     
  2. Curious Too

    Curious Too Well-Known Member

    Joined:
    Aug 31, 2001
    Messages:
    427
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    If MailScanner has stopped it's probably because the Clamav update has stalled. SSH into your server and kill the clamav update session and exim/mailscanner should start immediately.
     
  3. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    765
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    N.W. Iowa
    Ok, maybe I didn't make myself clear... if we want to disable the MailScanner so Exim will process mail without MailScanner can it be done.. ??

    Currently, ... If we stop MailScanner now, Exim doesn't send any mail till we restart MailScanner. I want to be able to stop or disable MailScanner, if the need arises, and still have Exim work properly w/o MailScanner.

    Hope this makes sense :)

    TIA,
    Mickalo
     
  4. nickn

    nickn Well-Known Member
    PartnerNOC

    Joined:
    Jun 15, 2003
    Messages:
    619
    Likes Received:
    1
    Trophy Points:
    18
    It can be done, you'd have to remove numerous lines from exim.conf as well as probably a few other little changes. I'll see about getting a howto written for this in the next few days :)
     
  5. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    765
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    N.W. Iowa
    that would definiately help :)

    I did some experimenting on my own, with the exim.conf file. In the section under the begin routers section, I commented out the following lines(see below code), and it seem to disable the MailScanner and still allowed Exim to send emails,... not sure this all that needs to be done tho
    Code:
    #!!#######################################################!!#
    #!!# Here follow routers created from the old routers,   #!!#
    #!!# for handling non-local domains.                     #!!#
    #!!#######################################################!!#  
    
    begin routers
    # Comment lines below
            # defer_router:
                    # driver = redirect
                    # allow_defer
                    # data = :defer: All deliveries are handled by MailScanner
                    # verify = false
    
     
Loading...

Share This Page