The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Disable mod_ruid2 question

Discussion in 'General Discussion' started by dudanger, Oct 10, 2016.

  1. dudanger

    dudanger Member

    Joined:
    Oct 10, 2016
    Messages:
    8
    Likes Received:
    3
    Trophy Points:
    3
    Location:
    Japan
    cPanel Access Level:
    Root Administrator
    Hello,everyone!

    I want visit web from http://ip/~username,but the new version close it.
    follew the guide , i need disable mod_ruid2 and mpm_itk ,then recompiling easyapache4
    but after do three steps, i Enable mod_userdir Protection, but output the error:

    but i am sure i disable the mod_ruid2,anything i missed?
    Thanks !

    Version :WHM 11.58.0.31
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  3. dudanger

    dudanger Member

    Joined:
    Oct 10, 2016
    Messages:
    8
    Likes Received:
    3
    Trophy Points:
    3
    Location:
    Japan
    cPanel Access Level:
    Root Administrator
    Thanks for yr replay.
    I got the output
    Code:
    .......
    No Match for argument: ea-apache24-mod_ruid2
    Loading mirror
    ....
    Package(s) ea-apache24-mod_ruid2 available, but not installed.
    No Packages marked for removal
    
     
    #3 dudanger, Oct 10, 2016
    Last edited: Oct 10, 2016
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Internal case EA-5117 is open to address an issue where "WHM >> Apache mod_userdir Tweak" can incorrectly detect mod_ruid2 as active on systems running EasyApache 4. I'll update this thread with more information on the status of this case as it becomes available. As a temporary workaround, check to see if an entry for mod_ruid2 exists in the /var/cpanel/conf/apache/main file on this system with a command such as:

    Code:
    grep ruid2 /var/cpanel/conf/apache/main
    If it does, open the this file in your preferred text editor, set the line for mod_ruid2 to "0", save the file, and then run the following command:

    Code:
    /scripts/rebuildhttpdconf
    Thank you.
     
  5. dudanger

    dudanger Member

    Joined:
    Oct 10, 2016
    Messages:
    8
    Likes Received:
    3
    Trophy Points:
    3
    Location:
    Japan
    cPanel Access Level:
    Root Administrator
    Thank you for yr replay.but

    Code:
    grep ruid2 /var/cpanel/conf/apache/main
    
    i got nothing,no *ruid2* in /var/cpanel/conf/apache/main.

    And do y get any other idea to fix this?
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Have you tried accessing the Mod_Userdir URL to see if it loads? The error output you see in the interface associated with case EA-5117 shouldn't prevent Mod_Userdir from actually working.

    Thank you.
     
  7. dudanger

    dudanger Member

    Joined:
    Oct 10, 2016
    Messages:
    8
    Likes Received:
    3
    Trophy Points:
    3
    Location:
    Japan
    cPanel Access Level:
    Root Administrator
    Last Day cPanel update to 11.58.0.32,last time was 0.31
    And save the option have no error output.

    But Visit Mod_Userdir URL output:
    http://IP/~username i got :

     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    This is unrelated to the original issue. The "Not Supported" message will occur when using the "CGI" handler with Apache Mod_Userdir. You will need to use another handler (e.g. suphp) if you want to utilize Apache Mod_Userdir. Documentation on Apache Mod_Userdir, and selecting PHP handlers with EasyApache 4 is available at:

    Apache mod_userdir Tweak - Documentation - cPanel Documentation
    Manage PHP Handlers in EasyApache 4 - EasyApache 4 - cPanel Documentation

    Thank you.
     
  9. dudanger

    dudanger Member

    Joined:
    Oct 10, 2016
    Messages:
    8
    Likes Received:
    3
    Trophy Points:
    3
    Location:
    Japan
    cPanel Access Level:
    Root Administrator
    Thanks !
    And that's make crazy total.

    Follow yr link and
    Code:
    # /usr/local/cpanel/bin/rebuild_phpconf --available
    ea-php55: cgi none
    ea-php56: cgi none
    ea-php70: cgi none
    
    Then i check the old cPanel Server(it cant use http://IP/~username,Version:11.58.0.25)
    Code:
    Available handlers: dso cgi none
    DEFAULT PHP: 5
    PHP4 SAPI: none
    PHP5 SAPI: dso
    SUEXEC: enabled
    
    And i want use that set (use ip), in the document,i need do
    Code:
    /usr/local/cpanel/bin/rebuild_phpconf --default=ea-php56 --ea-php56=suphp
    Something like this.

    the bad news was : cpanel output
    Code:
    ERROR: The ea-php56 PHP package does not support the dso Apache handler
    And
    ERROR: The ea-php56 PHP package does not support the suphp Apache handler
    
    The last version use and only use the cgi, how can do next ? install suPHP /DSO?

    Back the zero,my question was
    May i use the following URL visit to site by http://IP/~username in the vsersion 11.58.0.32 and after?

    Too much word ,thanks for yr time.
     
  10. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  11. dudanger

    dudanger Member

    Joined:
    Oct 10, 2016
    Messages:
    8
    Likes Received:
    3
    Trophy Points:
    3
    Location:
    Japan
    cPanel Access Level:
    Root Administrator
    Finally I fix it,Thanks again!
    And,EasyAapche4 did not support DSO module(That was take me some time).
     
    cPanelMichael likes this.
  12. Bhavin Mistry

    Bhavin Mistry Registered

    Joined:
    Oct 17, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hello,

    I am facing the same issue with my server (not supported message for PHP files).
    Can you please guide how did you exactly fix this? It may help a lot.

    Thank you.
     
  13. dudanger

    dudanger Member

    Joined:
    Oct 10, 2016
    Messages:
    8
    Likes Received:
    3
    Trophy Points:
    3
    Location:
    Japan
    cPanel Access Level:
    Root Administrator
    I am not sure my way is or not suit for y
    Because the error was in http://ip/~username

    and default cpanel did not support this .

    so i change then php handle and it's work.
    Code:
    1. EasyApache4  and check on suPHP
    2. Home >>Software >>MultiPHP Manager
         2.1 Set PHP Version per Domain  >>chose yr domain
         2.2 PHP Handlers >>change the default php handle CGI to suPHP
    3. Save 
    Best wishes
     
    cPanelMichael likes this.
  14. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    To update, the resolution for internal case CPANEL-9329 was included with cPanel version 60.0.6:

    Fixed case CPANEL-9329: Fix caching which leads to false mod_userdir / mod_ruid2 conflict.

    Thank you.
     
  15. dudanger

    dudanger Member

    Joined:
    Oct 10, 2016
    Messages:
    8
    Likes Received:
    3
    Trophy Points:
    3
    Location:
    Japan
    cPanel Access Level:
    Root Administrator
    Thanks ~ :)
     
    cPanelMichael likes this.
Loading...

Share This Page