SOLVED Disable MySQL strict mode - CloudLinux + MySQL 5.7

Galcea

Registered
Feb 8, 2013
1
0
51
cPanel Access Level
DataCenter Provider
Hello,

I have a problem with the STRICT_TRANS_TABLES and i want to disable it.
I tried some fixed from this threds: Disable MySQL Strict Mode and Strict Mode Thred

Code:
sql_mode=""
Code:
sql_mode=NO_ENGINE_SUBSTITUTION
Code:
sql_mode=IGNORE_SPACE,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION
After all of this when i test with mysql -e 'select @@GLOBAL.sql_mode;' i get
Code:
+-------------------------------------------------------------------------------------------------------------------------------------------+
| @@GLOBAL.sql_mode                                                                                                                         |
+-------------------------------------------------------------------------------------------------------------------------------------------+
| ONLY_FULL_GROUP_BY,STRICT_TRANS_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION |
+-------------------------------------------------------------------------------------------------------------------------------------------+
Also i updated the etc folder like Ignor sugested
cagefsctl --update-etc (like Igor sugested): CageFS and my.cnf
Nothing

Do you have eany other sugestions? I can't figure it out.

I use:
CLOUDLINUX 7.6 [c] v82.0.11 with PHP Governor
mysql Ver 14.14 Distrib 5.7.27,
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,216
463
Hello :)

I've been unable to reproduce this issue on a test environment. Could either of you share any errors seen in the output from the following command after restarting MySQL?

tail -50 /var/log/mysqld.log

Note: The MySQL error log can sometimes include identifying information about your server or database names. Ensure to scan any error output thoroughly before pasting it here in CODE tags.

I have a problem with the STRICT_TRANS_TABLES and i want to disable it.
Can you share the specific issue you were facing with STRICT_TRANS_TABLES?

Note, I recommend reading more about how this MySQL configuration value is defined on the following MySQL document and StackOverflow thread:


Thank you.
 

Michaelit

Well-Known Member
Aug 5, 2015
82
9
58
Greece
cPanel Access Level
Root Administrator
Hello @cPanelMichael,
It's really weird! Sorry for this late response. I finally completed that request through phpmyadmin tool as a root. I really don't know why that happened.
Although days have passed, i don't know if my mysqld.log file could help find out the reason.

I attach the log file however as i see it's the same notice again and again!
 

Attachments

Michaelit

Well-Known Member
Aug 5, 2015
82
9
58
Greece
cPanel Access Level
Root Administrator
Unfortunately this is a temporarily solution since the mysql service will be restarted. I attach the new mysqld_log.txt file in case that you find out something suspicious. It's really weird as i don't know if i have done something wrong with /etc/my.cnf file.
phpmyadmin tool as a root gives me this temporarily solution!
 

Attachments