SOLVED Disable MySQL Strict Mode?

kiopeed

Well-Known Member
Jan 11, 2017
69
9
8
cairo
cPanel Access Level
Root Administrator
welcome all
please how i can Disable Strict situation php from whm
Since all my work has been disrupted
Due to the activation of the strict situation
With install cpanel today
Special request and please from the company cpanel.net Stop complications
All users are not experts
I hope to solve this problem and all my work are stopped :(

please help
 
Last edited by a moderator:

kiopeed

Well-Known Member
Jan 11, 2017
69
9
8
cairo
cPanel Access Level
Root Administrator
All my work have been disabled due to activation mySQL Strict Mode
i need Disable mySQL Strict Mode
please help me i need stop this from whm
I am not an expert in executing command .
I hope the solution from whm
 

kiopeed

Well-Known Member
Jan 11, 2017
69
9
8
cairo
cPanel Access Level
Root Administrator
My language is not English and I am translating you from Google
As much as the volunteer
To show you the correct translation
I do not understand what I sent this
I do not know how to apply this
Is there a simplified explanation from you
Or video please

Why did she cpanel.net Activating this disturbing situation
why cpanel why why why
my work is stop
 
Last edited:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Hello @kiopeed,

Can you let us know the contents of the /etc/my.cnf file on this system?

Thank you.
 
  • Like
Reactions: Andrews Ayeni

kiopeed

Well-Known Member
Jan 11, 2017
69
9
8
cairo
cPanel Access Level
Root Administrator
yes mr. @cPanelMichael
this file from /etc/my.cnf
I have done this
It was restarted whm

Code:
# For advice on how to change settings please see
# http://dev.mysql.com/doc/refman/5.7/en/server-configuration-defaults.html

[mysqld]
performance-schema=0
#
# Remove leading # and set to the amount of RAM for the most important data
# cache in MySQL. Start at 70% of total RAM for dedicated server, else 10%.
# innodb_buffer_pool_size = 128M
#
# Remove leading # to turn on a very important data integrity option: logging
# changes to the binary log between backups.
# log_bin
#
# Remove leading # to set options mainly useful for reporting servers.
# The server defaults are faster for transactions and fast SELECTs.
# Adjust sizes as needed, experiment to find the optimal values.
# join_buffer_size = 128M
# sort_buffer_size = 2M
# read_rnd_buffer_size = 2M
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock

performance-schema=0
# Disabling symbolic-links is recommended to prevent assorted security risks
symbolic-links=0

performance-schema=0
log-error=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid
default-storage-engine=MyISAM
innodb_file_per_table=1
max_allowed_packet=268435456
open_files_limit=10000
sql_mode=""
i put the code sql_mode=""

This does not work
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
i put the code sql_mode=""

This does not work
Hello @kiopeed,

Did you restart MySQL after making the change? You would do so with the following command:

Code:
/scripts/restartsrv_mysql
Once you do that, let us know the output from the following command:

Code:
mysql -e 'select @@GLOBAL.sql_mode;'
Thank you.