The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Disable Outgoing SMTP

Discussion in 'E-mail Discussions' started by Mini, Sep 3, 2005.

  1. Mini

    Mini Well-Known Member

    Joined:
    Mar 4, 2005
    Messages:
    98
    Likes Received:
    0
    Trophy Points:
    156
    Hi all,

    I would like to disable outgoing SMTP for my clients. I would like them to use their ISP outgoing SMTP servers because of spamming issues.. How would I achieve this?? Oh and I am using WHM/cPanel..

    Kind Regards,
    Mini
     
  2. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    166
    If you have a server-side firewall, which you probably do, the easiest way would be to block access to port 25, or whichever port you use for SMTP.

    This way external clients would not be able to connect to send mail without preventing Perl, PHP and the like from doing so.
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,472
    Likes Received:
    20
    Trophy Points:
    463
    Location:
    Go on, have a guess
    IIRC, that's the purpose of the WHM > Tweak Security > SMTP Tweak.
     
  4. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    166
    Yep, that sounds more like it.

    My post makes somewhat no sense after I took the time to re-read the inital post and grasp the actual question being asked!
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,472
    Likes Received:
    20
    Trophy Points:
    463
    Location:
    Go on, have a guess
    You were right, it's just that that option does it for you by restricting (through iptables) who can connect directly to port 25 outgoing on the server.
     
Loading...

Share This Page