The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Disable ServerSignature Off - Not Working

Discussion in 'General Discussion' started by bls24, May 3, 2008.

  1. bls24

    bls24 Well-Known Member

    Joined:
    May 12, 2007
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    I've done the following:


    I did notice a bit at the top of the conf:
    ...I ran this after I exited pico:
    /usr/local/cpanel/bin/apache_conf_distiller --update




    And when I reloaded my site the headers still show. Any ideas as to what I may have done incorrectly?
     
  2. jdlightsey

    jdlightsey Perl Developer III
    Staff Member

    Joined:
    Mar 6, 2007
    Messages:
    126
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Houston Texas
    cPanel Access Level:
    Root Administrator
    The ServerSignature directive only prevents the display of a something like this at the END of auto-generated pages like directory listings:

    "Apache/1.3.41 Server at www.lolkitten.cat Port 80"

    If you're talking about the server information at the top of the Apache Status page, there's no way of supressing that output and no reason to do so since you can only view it from within WHM.

    If you are talking about the footer message you see in directory listings and error pages, you should also check to make certain ServerSignature is not being specified anywhere else. If you had it set in a VirtualHost include, for instance, that would take precedence over whatever setting you had specified globally.
     
  3. d_t

    d_t Well-Known Member

    Joined:
    Sep 20, 2003
    Messages:
    243
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Bucharest
  4. robb3369

    robb3369 Well-Known Member

    Joined:
    Mar 1, 2008
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Use mod_security...

    If you are running mod_security (via EA3), just add it to the modsec2.user.conf file:
    Code:
    SecServerSignature " "
     
Loading...

Share This Page